Has this happened to you too?


4 replies to this topic
  • b-bike

Posted May 20, 2004 - 06:17 PM

#1

The last time I had my "Blue Beast" out for a spin, the inspection cover for checking the flywheel timing came loose (almost all the way off). When I stopped to chat with the fellas I was riding with I noticed fresh oil on my boot, foot peg, lower frame rail & counter sproket guard. Thank God I was able to catch it before it came all the way off and ran the oil completely out the engine!! :thumbsup:

So... Am I the only one to have this happen to there bike?

Boyd

  • Sean_McCutcheon

Posted May 21, 2004 - 01:36 AM

#2

No it happened to my buddy who has a 2000 WR400F. You have to check and tighten every once in a while.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • probracing1

Posted May 21, 2004 - 06:40 AM

#3

Ha! It happened to me and my buddy roosted me in the left stator cover 2 seconds before I happened to notice it....changed oil--no damage done.

  • YZ400Court

Posted May 21, 2004 - 11:10 AM

#4

One of the TTRs has metal plugs that fit the YZ/WR covers. They seem to stay put better although I can't for the life of me remember which TTR it was.

  • b-bike

Posted May 21, 2004 - 06:21 PM

#5

One of the TTRs has metal plugs that fit the YZ/WR covers. They seem to stay put better although I can't for the life of me remember which TTR it was.


I'll check the ones off my daughter 03 TTR-250.

If thay fit... I'll just swap em. :awww: :lol: :thumbsup:

Boyd





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.