need help quick please

7 replies to this topic
  • mxracer32

Posted April 06, 2004 - 04:22 PM


i have a 1999 yzf400 and i just reset the time and its right i think cause it will run but when it start it backfires alot but it wont do it if u leave the choke on and also when u turn the choke off and keep it at a high idle it will run then when u let off it will die like it has ran out of gas. any thing will help thanks

  • Fastest1

Posted April 06, 2004 - 04:47 PM


When you say you "just reset the time" what do you mean? Cam timing or ignition timing? I actually suspect a dirty carb, but I would really like some answers. When was the last time it was running? What happened that made you change something? Fresh gas? plug?

  • mxracer32

Posted April 06, 2004 - 04:58 PM


it was the cam timing and i reset it cause i put new rings in it and piston and i got a new plug and fresh gas in it to. but i dont get y it dont do it when i keep the choke it runs fine. its been about 2 months since it was ran.

  • Fastest1

Posted April 06, 2004 - 05:03 PM


Are you saying it only runs with the choke on? or off?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gfergtr74

Posted April 06, 2004 - 05:03 PM


Check and clean the carb. The problem is probably there.

  • mxracer32

Posted April 06, 2004 - 05:08 PM


when i go to start it i turn the choke on and it starts and then it will run just fine then when i go to turn the choke off it will start to backfire and want to die out.

  • yamaha.dude

Posted April 06, 2004 - 06:03 PM


The old "upside-down-slide-in-the-carb" trick?


  • sirthumpalot

Posted April 07, 2004 - 01:34 AM


YOu said it has been 2 months since it was run. Did it run OK before the 2-month wait? If yes, then clean the carb. If you are not sure or you did not run it before putting it away for storage then check the carb slide as suggested above, re-check the cam timing and valve clearances, clean the carb and let us know the result.

Related Content

WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.