Sub frame wear

2 replies to this topic
  • w_ahhh450

Posted April 04, 2004 - 01:01 AM


Anyone else have wear from the chain on the rear subframe.
Me and a mate I ride with gave got what seems to be excessive side movement of the chain. He has put another piece of steel, stainlees I think.But if I go for a fix I'll probably try a bit of alloy.
Went for a ride today and was very wet and muddy and I think the chain is totalled.Have a new Regina X-ring chain and supersprox sprockets to go on soon.And a new rear tyre? I'm goin to try the new Michelin ac10 I hope it works well in the mud and sand.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • lipskid

Posted April 04, 2004 - 05:52 AM


Yeah, when the chain gets a bit loose, they do that. Mine's getting chewed up pretty bad. Thanks for reminding me, I need to get something on there to protect it. :)

  • Ronnie Mac

Posted April 04, 2004 - 06:15 PM


My chain slapped really bad against the sub frame, so I ajusted the slack to spec and put a 1/8 inch piece of rubber under my chain guide at the swing-arm. You have to lossen the allen bolts that hold it on. Cut to fit a 6"or so piece, tighten it down and it shou :thumbsup:ld work. Good luck.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.