Chain/Swing arm wear on 02?

1 reply to this topic
  • Sparky_So_Cal

Posted April 11, 2002 - 08:14 AM


I have been following these concerns and was wondering if anybody w/ an 02 has had this problem? I got my bike in December and haven't checked it out yet. Is this a problem w/ just the 00's and 01's? Anybody out there w/ any info on the 02's would be greatly appreciated. I should be tearing my rear asseembly down in the next few weeks for lubing and revalving of shock. I will post anything i find.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tony_t.

Posted April 11, 2002 - 09:02 PM


The 2002 model still has the same problem. It only took a few rides before mine started to show some wear on the swingarm.

Related Content


Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.