Jump to content

  • Follow us:

  • Facebook
  • YouTube
  • Twitter
  • Google+
  • Instagram
  • RSS Feed
  • Google+





Related Garage

BMW F650GS ABS 2003.jpg

BMW F650GS ABS (2003)


Owner: ArnoldinIdaho
Added on January 18, 2017


Related Reviews

MZ TS250 1973


No reviews available
Be the first to review this

Honda CBR300R 2015


Last review by atown8605
* * * * -

Ducati 888 SPO 1991


Last review by jakepeewee
* * * * *

KTM 1290 Super Duke R 2015


Last review by CRF450XINOZ
* * * * *

KTM 1290 Super Duke R 2014


No reviews available
Be the first to review this
Photo
- - - - -

Triumph Legend No Spark.


  • Please sign in to reply

No replies to this topic
  • ACE370

    TT Member

25 posts
Location: Texas

Posted November 06, 2016 - 11:20 AM


I acquired a 2000 Triumph Legend with 2,000 miles on a trade not running and missing Coils. After buying a new battery, replacing all 3 coils, plugs, wires, and the entire wiring harness... There is still no spark.. I've also bypassed the stand safety and clutch safety. All fuses are great. What do I check now? Out of ideas here.

 

Only clues i have is that on 2 instances, after letting the battery charge over night, I got it to spark on all 3 plugs for a moment and then back to nothing for seemingly no apparent reason. This happened with the original igniter., Instantly after replacing the igniter, the same thing occurred and then back to nothing. 

 

I use a Fluke DVOM for all testing. 

 

ANY info or ideas would be much appreciated.







Related Content

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.