2007 yz450f O ring found in oil!


11 replies to this topic
  • romansam

Posted October 07, 2016 - 08:41 AM

#1

Hey guys new to the forums but I've been using it for a while. OK I'll get to it.. Ive been slaving on my bike for a few days now, won't start and wouldnt kick down all the way (fixed the kicking)and clutch won't disengage fully. Bike sat for a year befor this, so first I fixed the timing, it was off by a tooth, this allowed me to kick without it locking up (timing was off because the bike slipped well it was on and hit a hard surface and skipped a tooth) , I also changed the oil and filter. Well it still wouldn't start.. so next I replaced the spark plug. Still wont start, unplugged the kill switch and now atleast i get a back fire everyonce and a while. so then i tore everything off the bike except the engine and took the carborator off , disassembled it and cleaned it. Put it back on and I've reused the fresh oil I put in. Still will not start.. now I'm back to checking the timing. Drained oil and took the left side cover off the top cover off and the spark plug out with oil pan underneath. I think the cams are off the marks on the timing sprockets.. well get to that later.. problem is I looked into my oil pan and found an o ring!!! I don't know what it's from. This pan is only being utilised this time around. I haven't used it the other times I drained the oil. (I did use it on another motorcycle that I just changed oil on) well I'm scared it might be from this bike but I have no idea where to look. It's about the size of the threads of a spark plug( the wider side that sparks). Outer diameter is about 11 mm inner is about 8 mm. any idea?

  • stevethe

Posted October 07, 2016 - 09:38 AM

#2

Possible oring is from the top timing plug.
Google a picture of the cam position and timing marks for a 07 YZ450.
Put a brand new pilot jet in it. They are difficult to properly clean.

  • romansam

Posted October 07, 2016 - 10:35 AM

#3

Not sure what a timing plug is. All the Jets seemed to be allowing fuel straight through them with no problems at all. I would suspect it more if it just ran weird.. but this thing won't fire at all

  • romansam

Posted October 07, 2016 - 10:37 AM

#4

Oh the top plug on the left side case. No the threads are atleast twice the size of this o ring

  • romansam

Posted October 07, 2016 - 10:39 AM

#5

Went back through the timing. Seems to be as close as I can get this thing to descriptions online. 13 pins between the 2 top timing marks, Allen wrench in spark plug whole to indicate actual tdc, all marks line up as good as possible.. maybe a tooth off with stretched chain. But I don't think that would stop it from atleast trying to start.
Best I get is back fire every 5 or so kicks.

  • stevethe

Posted October 07, 2016 - 11:44 AM

#6

If it's off a tooth it likely won't start.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • romansam

Posted October 07, 2016 - 11:50 AM

#7

Well I've tried both positions that are close to perfect timing as far as all the pictures go. Won't work. It's as close as I can get the timing with 13 pins the marks. This thing won't even attempt to start like I said I get a back fire tops every 5 or so kicks. Won't fire on a rolling start
1475869816104.jpg position it's at now
1475869836291.jpg position I tried befor

  • romansam

Posted October 07, 2016 - 11:53 AM

#8

1475869985559.jpg not sure why the first one was upside down. This is an upright picture of what it's at now

  • grayracer513

Posted October 07, 2016 - 12:20 PM

#9

The O-ring was probably one of the 3 small ones at the oil filter cover. 

 

The timing marks on your exhaust cam are rather indistinct.  Makes it difficult to see in the pictures.

 

Have you checked for spark? 



  • romansam

Posted October 07, 2016 - 12:54 PM

#10

Well it's a new spark plug and it's backfiring everyonce and a while. What's the best way to check for spark?

  • romansam

Posted October 07, 2016 - 12:58 PM

#11

1475873896223.jpg any better?

  • grayracer513

Posted October 07, 2016 - 01:27 PM

#12

Well it's a new spark plug and it's backfiring everyonce and a while. What's the best way to check for spark?

 Remove the coil from the spark plug (probably helpful to also remove the plug; makes it easier to turn over) and reconnect it to the harness.  Put a plug in it and hold the metal body of the plug firmly against the engine (you won't get "bit" if you hold it against a good ground, but if you ease up, you might).  Turn the engine through and watch the plug gap.  The spark should be blue/white and have an audible snap to it.
 

attachicon.gif20161007_165720.jpg any better?


Yes, and that looks correct, assuming you have the crank positioned right.







Related Content

Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.