WR450F '2012 capricious headlight


2 replies to this topic
  • WRF-Rowdy

Posted May 24, 2016 - 04:48 AM

#1

1) I switch on ignition, headlight stays off, fine so far.

2) I start the engine, headlight stays off, weird, but ok with me.

3) I get going, headlight comes on, stays on.

4) Once it had lit up, it stays lit, no problemo.

5) I kill engine, headlight stays on, cool and ok.

6) I switch off ignition, headlight shuts off.

 

Is that basically correct?

Does the EFI decide to delay headlight till seizably "after" engine firing up?

 

The weird part is 2)  :  The time (distance??) the headlight "waits" before beginning to light up varies a lot.

Sometimes it stays off the whole ride from the movies back home (bad), can't be right.

 

So: What's wrong with my WR, and why?

 



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • SatansReverence

Posted May 26, 2016 - 02:43 AM

#2

Check your headlight relay and the headlight plug.

 

Should start with park light > headlight after engine start > Headlight until ignition turned off.



  • Agazza

Posted May 29, 2016 - 02:35 AM

#3

I would like to mount a off switch for trail riding, better to fill up the battery when the sun is out, anyone changed switch?




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.