Electrical Short - Help!

4 replies to this topic
  • jimmym

Posted January 29, 2016 - 06:31 PM


I did a very, very bad thing... and really need some help.


2011 WR450F. I was attempting to wire a neutral light into the switched plug behind the headlight, and forged a makeshift connector to fit the existing spade connectors in the plug. Everything looked great, but when I turned on the power it kind of sparked, then I lost power in the display. It looks like my connector spread too wide and touched a neighboring pin. I now have zero power up front.


The main fuse checks out ok, but somehow I've lost all power to the main switch and multi-function display. I have checked the service manual, as well as followed the cables, but can't find an inline fuse or other reason for losing power. I'm lost here, and really hoping someone can help me understand what I've done, and how I can fix it. I have my first big ride of the year planned for tomorrow morning, and praying I didn't blow it (yup, I blew it).


This is the connector I shorted out: IMG_20160129_104446.jpg



After performing a range of voltage and continuity tests, I have come to the conclusion that my multi-function display is toast. There is a possibility that the main switch is fried, or even some other component, but I'd put my money on the MFD at this point. So, I'm hoping that somebody, somewhere can corroborate my findings.


If this is truly the problem, does anyone have a lonely multi-function display they'd like to sell?  



Edited by jimmym, January 29, 2016 - 10:32 PM.

  • jimmym

Posted January 31, 2016 - 03:35 PM


Can a Trail Tech device replace my blown OEM multi-function display unit? I would prefer to get something with additional functionality since I'm spending the money anyway, but I can't tell if the Endurance II/Vapor/Striker utilizes the same connectors, and effectively replaces my failed OEM speedometer. Does anyone have any experience with swapping for a trail tech device?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted January 31, 2016 - 05:04 PM


The same connectors? Only power and ground will be used from stock, and those oem connectors will have to be removed, or bypassed.

  • jimmym

Posted February 01, 2016 - 09:41 AM


The same connectors? Only power and ground will be used from stock, and those oem connectors will have to be removed, or bypassed.


Got it. That's what I was afraid of. I was hoping that the trail tech devices would connect in and replace the OEM speedometer/MFD, but it's never that easy (or affordable).


Considering that the main switch and other components are all wired through the MFD, I think I'll just replace the failed device for now rather than delve deeper into electrical problems. 



  • jimmym

Posted February 07, 2016 - 08:28 PM


In case anyone happens to make the same stupid mistake... a replacement speedometer/odometer/multi-function display resolved the problem. The price of a new device runs approximately $400, fortunately eBay saved the day at a fraction of that price. I'll be back in the seat tomorrow afternoon!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.