Battery rapidly draining wr450f


1 reply to this topic
  • Dirtbiker24

Posted December 25, 2015 - 07:07 PM

#1

hi guys im having a bit of electrical trouble with my 2005 wr450f at first the battery wasnt charging so i did various tests to determine what was at fault and discovered it was the regulator, the previous owner installed a trail tech system (stator and regulator) so i ordered a new trail tech regulator and installed it the bike wasnt charging again i then noticed that the batterys voltage was dropping considerably as soon as the ignition was turned on (it goes down .1 per second) so i disconnected all the lights and its still dropping battery voltage. what could it be?   


Edited by Dirtbiker24, December 25, 2015 - 07:12 PM.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Dualsportwr450

Posted December 26, 2015 - 11:18 PM

#2

I'm thinking you got a wire between the stator and regulator that is grounding out. Have you checked ohm resistance on the stator. Look for pinched wires grounding out
Cut all the zip ties on the harness and make sure the vibration didn't fray a wire under the zip tye to the frame




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.