2013 yz450 wont stay on



3 replies to this topic
  • alexp96

Posted October 16, 2015 - 08:48 AM

#1

hi I got 2013 yz450 a few weeks ago. Everything was running right until i let it sit for 4 days and now the bike starts but shuts off to keep it on you have to stay in throttle does anyone know what it might be. A few friend told me it could be the spark plug. but I'm not sure


Edited by alexp96, October 16, 2015 - 09:10 AM.


  • grayracer513

Posted October 16, 2015 - 09:51 AM

#2

Will it stay running if you use the cold start knob, or just turn the idle up?  



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • alexp96

Posted October 16, 2015 - 10:01 AM

#3

Will it stay running if you use the cold start knob, or just turn the idle up?  

nope just kept shutting off



  • grayracer513

Posted October 16, 2015 - 03:31 PM

#4

Sounds like a sticking injector.  Check it for codes.  Might try a top tier injector cleaner fuel additive.  Read the instructions on the label and figure when they say a full tank, they mean 16 gallons. 







Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.