bike is destroying carb seals and o rings!?



35 replies to this topic
  • ramcharger

Posted September 02, 2015 - 04:27 PM

#1

I have a yz400f and the carb was rebuilt last year and then the seals and o rings went bad. Then i ordered a 450 carb and those went out to. Anyone know why its doing this. 



  • ramcharger

Posted September 02, 2015 - 04:39 PM

#2

could it be my carb is just worn out and needs replaced? the slide has side to side play if that helps



  • BushPig

Posted September 02, 2015 - 04:42 PM

#3

could it be my carb is just worn out and needs replaced? the slide has side to side play if that helps

 

Do you use fuel with Ethanol in it?



  • ramcharger

Posted September 02, 2015 - 04:56 PM

#4

Do you use fuel with Ethanol in it?

i just use premium at shell. not sure if that has ethanol or not



  • BushPig

Posted September 02, 2015 - 05:02 PM

#5

i just use premium at shell. not sure if that has ethanol or not

 

It might be worth finding out... because ethanol is known to attack seals and fittings in carbs.



  • ramcharger

Posted September 02, 2015 - 05:08 PM

#6

It might be worth finding out... because ethanol is known to attack seals and fittings in carbs.

ok but i ran regular not premium in my xr200 and it doesnt have problems. But i guess regular and premium gas probably has different percents of ethanol



  • dbart250

Posted September 02, 2015 - 07:07 PM

#7

Id make sure you arent using e85. It has a higher octane rating so maybe the pump displays 105? Not sure, ive never gotten it. I live in the corn belt and have little choice but to run 10% ethanol without issues. Makes me think you are running 85. Do you use any fuel treatments?

  • Krannie McKranface

Posted September 03, 2015 - 03:12 PM

#8

If you are not treating your gas for ethanol, you will continue to have problems, and even worse, internal carb corrosion.



  • ramcharger

Posted September 03, 2015 - 05:56 PM

#9

Id make sure you arent using e85. It has a higher octane rating so maybe the pump displays 105? Not sure, ive never gotten it. I live in the corn belt and have little choice but to run 10% ethanol without issues. Makes me think you are running 85. Do you use any fuel treatments?

The premium I get at shell says its a 92 or 93 octane, cant remember. I also live in a farming community. Town only has 4-5 thousand people in it. Rest is just farms. I normally do not use fuel treatments. Last time I put in locus oil fuel cleaner in it shortly after that is when the o rings started going bad. Heres the link for the cleaner. http://www.summitrac...rts/luc-10020-1



  • ramcharger

Posted September 03, 2015 - 05:57 PM

#10

If you are not treating your gas for ethanol, you will continue to have problems, and even worse, internal carb corrosion.

What do i put in the gas to treat for ethanol and what is internal carb corrosion? Still new to engines and carbs. Im only 16



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted September 03, 2015 - 06:43 PM

#11

What do i put in the gas to treat for ethanol and what is internal carb corrosion? Still new to engines and carbs. Im only 16

 

Ethanol attracts moisture

Unabated, it will cause corrosion inside the carb, making it a mess to clean, if even possible.

Use Stabil, or Torco, or PRI-G, or whatever, every single tank full. 



  • Summit

Posted September 04, 2015 - 06:10 AM

#12

Try to find gas without ethanol. We have several stations here that advertise no ethanol and that's all I use for everything. In addition use startron treatment...it works!

  • Aka.Goose

Posted September 04, 2015 - 07:56 AM

#13

every single tank full. 

This is the very first thing I've ever seen you post that made me say, "Wait, WHAT?!?" I don't know anybody that uses fuel treatment every tank? I do know that the gas seems to go bad within weeks now, where just a few years ago it would last months?

 

Ram, are you using regular carb cleaner spray to clean your carb? (because that stuff will eat your seals too)


Edited by GOOSE 07 YZ450F, September 04, 2015 - 08:02 AM.


  • ramcharger

Posted September 04, 2015 - 08:08 AM

#14

This is the very first thing I've ever seen you post that made me say, "Wait, WHAT?!?" I don't know anybody that uses fuel treatment every tank? I do know that the gas seems to go bad within weeks now, where just a few years ago it would last months?

 

Ram, are you using regular carb cleaner spray to clean your carb? (because that stuff will eat your seals too)

no i havent used carb cleaner. just the lucas oil product. also the carb bore is worn out



  • Aka.Goose

Posted September 04, 2015 - 08:17 AM

#15

no i havent used carb cleaner. just the lucas oil product. also the carb bore is worn out

yeah, I caught a little of that in the chat last night...Not much if anything can be done once that's worn out, not even sure about the slide side to side play...But you say you had one rebuilt, and then purchased another one with similar issues? I didn't really catch that part...



  • ramcharger

Posted September 04, 2015 - 10:45 AM

#16

yeah, I caught a little of that in the chat last night...Not much if anything can be done once that's worn out, not even sure about the slide side to side play...But you say you had one rebuilt, and then purchased another one with similar issues? I didn't really catch that part...

yea the original is worn out and junk. then the shop ordered a used carb and the o rings went out on that and that carbs slide also has side to side play but not as bad as the original one



  • Aka.Goose

Posted September 04, 2015 - 10:57 AM

#17

I really want to help you out, but keep getting the feeling stuff just isn't adding up...what shop are you talking about? You are saying they rebuilt a carb that was "worn out junk"? and when that didn't work, they ordered you a used carb? but they didn't rebuild that one? :huh: and when you say the "rings went out" what do you mean? they were cracked/worn/leaking, what? What bike symptoms are you experiencing? What have you done to fix the symptoms? Aren't you the guy that said the shop rebuilt your entire motor but then it wouldn't start, but turns out you ran it a little, and then tried to bump start it after the timing was off?



  • Krannie McKranface

Posted September 04, 2015 - 10:58 AM

#18

Give up

He wants you to read his mind



  • Aka.Goose

Posted September 04, 2015 - 11:28 AM

#19

Give up

He wants you to read his mind

Haha...Partly out of guilt since I bailed on him in the chat last night out of frustration, I thought I'd give it another shot to help out since he is only 16...But now I feel like we're going to find out he's actually 18 but uses a birth certificate that says he's 16 because of a witness protection program or something, haha...Crazy info keeps popping up after the questions are partially answered.



  • grayracer513

Posted September 04, 2015 - 12:04 PM

#20

Ditch the carb altogether and find one from an '05-'09 YZ450F.  You'll be much happier.







Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.