2003 WR450 wiring help


8 replies to this topic
  • Codywp94

Posted June 28, 2015 - 12:26 PM

#1

Alright I am new and have been doing some reading and have a few questions. I bought a 03 wr450 that has a mc Indiana title. The bike does not have turn signals or horn which is needed in my state. I have a switch to turn the headlight and tail light on and off. I also have a ricky stator in it. So my question is I plan on buying led turn signals off of amazon along with a signal flasher and horn. I don't have the extra cash for a kit looking for some help from someone who has done this.

Now here are a few pictures of the bike.
0624152129b_zpsk8r4abkf.jpg0624152129a_zpsyc8xiliv.jpg0624152129_zps4tmlwa1f.jpg

Edited by Codywp94, June 28, 2015 - 10:23 PM.


  • Krannie McKranface

Posted June 28, 2015 - 06:39 PM

#2

Do a search for 'basic DS kit' on this forum and in google.

 

You need a rectifier, if the RS stator did not come with one.



  • Codywp94

Posted June 29, 2015 - 02:56 AM

#3

KRANNIE I believe the ricky stators do have the rectifier. I will have to make sure though. Thanks for the help too bud.

  • bobpara

Posted June 29, 2015 - 10:09 AM

#4

The nice part about a DS kit (like a Baja unit) is that all in one control on the laft handlebar that controls headlight, horn & blinkers. Otherwise your handlebars have some many rube-goldberg switches it looks like the flux capacitor from back to the future

Once you have the stTOR REWOUND (THE 'RICKY STATOR) the bar switch(es) are the next most important item



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Codywp94

Posted June 29, 2015 - 09:13 PM

#5

Ok I had the day off and took it riding. I laid it over while riding and now my headlight nor tail light work. This may be the problem (the previous owner had a button under the rear brake pedal that broke off). So I went to load it up in the truck runs fine Speedo works still so I look at the button and a wire but the peg and I heard/saw a small spark. This is when I checked my lights and a no go. I get it home take gas tank off to look at wires and follow them. I couldn't find the problem I have tried looking everywhere to find out why the lights quit working.

I checked bulbs and all is well, I also checked the fuses under the seat (it was in the rain for a little bit too but wouldn't expect this from water and not much). I have not owned a bike or quad with battery or a 4 stroke this seems to be a bit different. So I got tired trying to find the light cure and checked my valve clearance and my valves are in spec just on the low end. All intake where .102 and exhaust .203. I feel that it's weird the all seemed to be the same but no bigger sizes fit but a few had a little more room so to speak.
I will be either starting a new thread or adding this to the top. Thanks again guys and I am going to buy the tusk kit if I can get my lights and all working or could I just wire them to the tusk kit and be fine from the sound of it?

  • JVP

Posted June 30, 2015 - 07:01 AM

#6

The Tusk lighting kit should work fine.  I think you should start at the beginning when it comes to your electrical.  Who knows what the previous owner did.  The kit is a good price and the quality is fair to good.  My only suggestion is to screw the rear blinkers into the fender.  The double sided tape dose not hold up. Your Ricky Stator is a quality product.  It should have a rectifier with it.  This stator changes your old AC/DC system to a full DC system.  Your valve should be checked and within the specs as stated in your manual.  The intake and exhaust are set differently.



  • Codywp94

Posted June 30, 2015 - 07:59 AM

#7

Sounds great I plan on running my lights and all on the tusk harness so that should fix that problem. I will be doing that with the rear blinkers thanks for the heads up.
Yeah the valves all are in spec just will need to be shimmed soon. This 4 stroke stuff is new but doesn't seem bad. I am very happy with this bike it's just a blast.
This is the rectifier that from the ricky stator I believe.
0629152336a_zpsfst7avr7.jpg

  • JVP

Posted July 01, 2015 - 08:44 AM

#8

That is correct.  I suggest you go on the web and down load a manual for the stator. This will assist you on the wiring set up.  As you can seen there are two adjustment pots on the back.  One is factor set for they voltage output.  The other is for a delay wire.  You can use that wire for keeping one of the systems on for a few seconds after the motor shuts off. 



  • Codywp94

Posted July 01, 2015 - 09:33 AM

#9

JVP thank you very much. I have my tusk kit on the way and going to download the manual for the stator.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.