swapping motors


9 replies to this topic
  • MX450R

Posted June 04, 2015 - 05:32 PM

#1

Hey guys, I'm a lifer honda guy. That being said I've worked on all brands. I had an 07 yz450f motor roll in the garage yesterday, got it fixed and decided to ride it today. To a major surprise this bike was 4speed????? I thought 05 was the last year for that. How easy is it to swap motors on these and how can I identify an older motor? The owner just rides he don't keep up on bikes and this was a recent purchase for him.......I'm figuring he may be a little upset if I have to tell him his motor is 10 years old.

  • havek83

Posted June 05, 2015 - 06:19 AM

#2

The 07 should've been a 5 speed tranny. I have the 08 which isn't much differance between them. 05 was the last year of the 4 speed. There's two obvious answers to this one...either the motor was swapped or 5th gear is gone.

  • MX450R

Posted June 05, 2015 - 06:51 AM

#3

The 07 should've been a 5 speed tranny. I have the 08 which isn't much differance between them. 05 was the last year of the 4 speed. There's two obvious answers to this one...either the motor was swapped or 5th gear is gone.

I know that much....what I don't know is how to determine my (his) issue. Is there any way I can designate this an older motor....markings on the case, something externally that was changed that would tell the tell of which motor im looking at here???. I know timing plugs were changed over the years but chances are the previous owner probably kept his stator cover due to a known good stator so timing plugs are not a reliable enough determination. I know something is wrong or different, I just need proof of what I have



  • grayracer513

Posted June 05, 2015 - 07:09 AM

#4

The Gen1 YZ450 was built as a 4 speed from '03-'05. All of them after that were 5 speeds.  One of the most obvious differences between the Gen1 and the Gen2 ('06-'09) is that the older engine has an external oil manifold on the right side that transfers oil from the filter to the trans and the top end, and provisions for an external oil line on each side, below and behind the crankshaft center line.

 

A Gen2 will not have any bolt-on oil lines, but will have a hose barb on the right crankcase cover and one to match in front of the cylinder, as well as a dip stick in front of the cylinder on the left side.

 

A Gen1 head will have a plug in the old decompression shaft bore above the exhaust port, while in the Gen2, that bore was never drilled.

 

Another giveaway, if you remove the left side crankcase cover, is that the Gen2 magneto is built "inside out" with the stator mounted to the case cover, and the rotor mounted inboard on the crank with the open side facing out.  The Gen1 mounts the stator in the more conventional position on the crankcase.



  • MX450R

Posted June 05, 2015 - 08:11 AM

#5

The Gen1 YZ450 was built as a 4 speed from '03-'05. All of them after that were 5 speeds.  One of the most obvious differences between the Gen1 and the Gen2 ('06-'09) is that the older engine has an external oil manifold on the right side that transfers oil from the filter to the trans and the top end, and provisions for an external oil line on each side, below and behind the crankshaft center line.

 

A Gen2 will not have any bolt-on oil lines, but will have a hose barb on the right crankcase cover and one to match in front of the cylinder, as well as a dip stick in front of the cylinder on the left side.

 

A Gen1 head will have a plug in the old decompression shaft bore above the exhaust port, while in the Gen2, that bore was never drilled.

 

Another giveaway, if you remove the left side crankcase cover, is that the Gen2 magneto is built "inside out" with the stator mounted to the case cover, and the rotor mounted inboard on the crank with the open side facing out.  The Gen1 mounts the stator in the more conventional position on the crankcase.

Thanks so much gray, I have a  black oil hose running from the right side cover up around the front of the motor and going back into the center engine cases. I was curious about this too due to my old YFZ quads never had such a thing. Now I guess I know. He has an older motor in an 07 Frame. Now the question, Do I tell him what ive discovered or give him his "07" back that he is very happy with and never speak a word lol.

 

EDIT: After closely looking at google pics I see the differences, I do in fact have a newer motor.....with apparently a junk 5th gear


Edited by MX450R, June 05, 2015 - 08:13 AM.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 03yzf450-kuke

Posted June 05, 2015 - 08:31 AM

#6

Hooefully its an 03 motor. If so i wouldnt be complaining. 04 or 05 would be disappointing....
Oops sry didnt read the edited part

  • grayracer513

Posted June 05, 2015 - 08:41 AM

#7

The '03-'05 were almost completely identical engines except for the higher primary gearing that was added in '05.  Why would one be more desirable that another?

 

In fact, the '04 and '05 had an upgraded connecting rod and a beefier kick start assembly.  Both these parts were weak on the '03.  The '05 had a better head, too (port configuration)



  • grayracer513

Posted June 05, 2015 - 08:47 AM

#8

I have a  black oil hose running from the right side cover up around the front of the motor and going back into the center engine cases. I was curious about this too due to my old YFZ quads never had such a thing.

 

That is a Gen2 engine.  The Gen1 external manifold was steel, not rubber, and was held in place by 3 banjo bolts.  The hose you have is the pressure balance line that matches the internal air pressure in the feed oil storage area, the "tank", if you will, to the pressure in the crankcase to insure proper flow.  Quads didn't use the Gen2 until the '08 "R" model came out.  On Gen1 bikes and your quad, that hose ran from the cam cover to the oil tank or the frame head oil tank.



  • MX450R

Posted June 05, 2015 - 08:51 AM

#9

Now onto this, which makes everything start making more sense. This thing was extremely hard to shift....actually the shifter was stripped when it come to me and now I know why, although the shift was not why it come to me after riding it I could for sure see why it was stripped. So whats causing this 5th gear issue? bent forks, bad drum? I had the oil drained and seen no signs of metal. When you try to go from 4th to 5th its like your hitting a positive stop, there is no give to the shifter at all after 4th.



  • grayracer513

Posted June 05, 2015 - 08:58 AM

#10

It is possible, although it takes work, to put the old 4 speed in the newer engine.  Doesn't happen very often, though.  You likely have some sort of internal fault either with the shifter linkage behind the clutch, or deeper, with the forks and cam.







Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.