2014 yz450 w/ 14 hours bad ECU ?


5 replies to this topic
  • weitzc

Posted May 18, 2015 - 12:09 PM

#1

I've been having trouble with my bike for over a month now. This bike is 100% stock. It was running perfect for the first 13 hours then it miss fired a couple of times and now it will run normal for about 10 minutes then after a short break the rpm meter shows that the bike is idling at 4300 rpm when I know it's about 1/2 that speed. If I Rev the motor the Rev limiter kicks in way to early. I bought a gytr tuner so I could check for any error codes and it shows error code 13. In my manual it tells me to check inlet air pressure sensor and if that is OK replace ECU. I have no way to check the sensor so I was going to replace it but after getting the air box out of the way I discovered that that sensor is screwed to the throttle body with an Allen screw that has a tit in the middle so I'm assuming yamaha doesn't want me messing with it. Should I replace the ECU? What could have caused it to go bad?

  • grayracer513

Posted May 18, 2015 - 12:21 PM

#2

No, you shouldn't replace the ECU when the ECU is telling you that the MAP sensor is bad.  The screw is likely a "security Torx" rather that a pegged Allen, but either way, you should go by the codes and buy a wrench that will work, or take the bike to a shop, tell them it has a code 13, and ask them to test the sensor. 



  • 15thumper

Posted May 18, 2015 - 12:37 PM

#3

These bikes are not your 1988 yz250 take it to a good dealer and have piece of mind that its being fixed properly

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • weitzc

Posted May 24, 2015 - 11:44 AM

#4

I understand the best thing to do is take it to a shop that has the proper diagnostic equipment. I would really prefer not to. I took apart and greased all the electrical connectors and inspected all the wires. Everything looks good.

When I start the bike with the tuner connected and it's running good. The tuner shows 2100 rpm at idle and air pressure at 101 kPa the hour meter also shows 2100 rpm. When it starts to run bad I get error code 13. The tuner still shows rpm is 2100 and air pressure is 101 but the rpm on my hour meter shows 4200 rpm.

In my manual for error code 13 it says check air pressure sensor. It should be 101 kPa at sea level to 1000 feet. If sensor if functioning proper replace ECU.

Air pressure sensor is $100 and ECU is $300. The shop will charge me $175 to diagnose problem.

What should I do?

  • Yzrider1023

Posted May 24, 2015 - 12:03 PM

#5

Take it in that way you won't have to buy one then it turns out to be the other

  • weitzc

Posted June 09, 2015 - 02:02 PM

#6

Replaced intake air pressure sensor. Bike runs like new again.





Related Content

Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Forums
Photo

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies
Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.