Yz450f rebuild help

26 replies to this topic
  • 03yzf450-kuke

Posted March 19, 2015 - 01:39 PM


Well no I drained the oil and coolant before removing the cc cover so that couldn't be it

  • grayracer513

Posted March 19, 2015 - 02:22 PM


You're not following.  The leak that caused your oil to get contaminated was at the crankcase cover gasket and O-ring, not the water pump.

  • 03yzf450-kuke

Posted March 19, 2015 - 03:35 PM


I don't understand. Why do you suggest those seals were leaking? I didn't even replace those seals just the impeller seals and it fixed my problem

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted March 20, 2015 - 06:26 AM


You had the right cover off to replace the shaft seals.  You put it back together with the old gasket and O-ring? 

  • 03yzf450-kuke

Posted March 20, 2015 - 08:31 AM


Yes that is correct. But I found the coolant in my oil when I drained oil before taking cover off.I know its frowned on to re use gaskets but I did any way and no leaks

  • ghorn0103

Posted April 07, 2015 - 05:11 PM


Turns out it was one of the dowl pin o-rings between the right crank case cover and case or the one between the cylinder and crank case. Wasnt sure which so i replaced both o-rings and dowell pins. Completely solved my issue. Thank yall for all the help!

  • 03yzf450-kuke

Posted April 08, 2015 - 02:34 AM


Ride on brotha

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.