12+ headlight on my 09 wr450f


20 replies to this topic
  • JustG

Posted March 11, 2015 - 05:32 AM

#1

Purchased a headlight assembly for a 2012 wr450f. I know the plate will bolt right up, but will I need an adapter for bulb? On my 2009 I can't remember if it was a standard 3 prong h4 socket.

My bike suspension is being tuned and do not have close access. Will be picking up from MCR friday and would like to get bike together asap. It's getting nice out!

New to TT by the way. Thank you!

  • toten

Posted March 11, 2015 - 06:17 AM

#2

Looking at the parts fiche on bikebandit it appears that the 2012 uses an H4 but 2009 isn't. The 2009 has a small wiring plug that stays attached to the headlight assembly. If you end up doing any rewiring I'm interested in the wiring harness end of that plug, so I can make a 2009 headlight work on my 2003. 

 

I'm not sure that there's an adapter available, the 2009 uses an odd bulb. 



  • Krannie McKranface

Posted March 11, 2015 - 06:40 AM

#3

It does not bolt 'right up' as it will be in the wrong place, until you alter the mounting tabs

I cut the factory wiring harness and spliced (soldered) the '12 plug.

Then I changed it again using the Ricky Stator mini HID kit, which fits in the factory lamp mount.

 

IMG_3478_zps9a51d382.jpg


Edited by Kah Ran Nee, March 11, 2015 - 06:40 AM.


  • JMundy

Posted March 11, 2015 - 07:10 AM

#4

 If you end up doing any rewiring I'm interested in the wiring harness end of that plug, so I can make a 2009 headlight work on my 2003. 

 

 

 

I rewired my 2007 and still have some of the parts.  Message me what you are looking for and we can work something out



  • JustG

Posted March 11, 2015 - 07:35 AM

#5

From the little bit of info I found, I assumed it was bolt on.

In your picture, it still looks a little high

I'll be using the ADVmonster LED H4.

  • JustG

Posted March 11, 2015 - 07:55 AM

#6

Or could it be simple as replacing with this h4 connector. Would this be correct?
http://www.amazon.co...l3nL&ref=plSrch

  • JMundy

Posted March 11, 2015 - 08:13 AM

#7

Or could it be simple as replacing with this h4 connector. Would this be correct?
http://www.amazon.co...l3nL&ref=plSrch

 

looks like it would work, or cut the plug off yourself and wire it in.  Thats essentially what you are doing with that adapter



  • JustG

Posted March 11, 2015 - 08:21 AM

#8

I suppose my confusion would me the h6m plug has two wires, and the h4 with 3.

  • JMundy

Posted March 11, 2015 - 08:28 AM

#9

i had same issue, well not really an issues but its for a high / low switch.  if you are not running that, just pick which one you want to power and stick the hot from the h6m to the mode you want to run.  In my case, i run on high on my Cyclops LED bulb, so i have one wire to ground, other to high beam and the low beam is not connected and just tucked away



  • toten

Posted March 11, 2015 - 08:33 AM

#10

What type of bulb is the 2012? Is it an H4?



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted March 11, 2015 - 01:18 PM

#11

It is mounted so the light beam does not hit the fender

If you mount it all the way down, 30% of your light is gone.....



  • foggy3061

Posted March 12, 2015 - 09:37 AM

#12

From the little bit of info I found, I assumed it was bolt on.

In your picture, it still looks a little high

I'll be using the ADVmonster LED H4.

Probably because Kah Ran Nee has different triple clamps. It bolts right up and sits lower on the standard 2007-2011 triple clamps / headlight mounts.

 

20140823_160823._zpsyhng37n0.jpg

 

What type of bulb is the 2012? Is it an H4?

 

The 2012 uses a 12V-35/35W HS1 bulb so requires a H4 style 3 pin bulb connector.


Edited by foggy3061, March 12, 2015 - 09:39 AM.


  • JustG

Posted March 12, 2015 - 09:50 AM

#13

Thanks for the clarification and info, I didn't even notice his triples.

  • BrianTheDog

Posted July 25, 2015 - 06:21 PM

#14

I realise this thread is a bit stale. But I'm going to be wiring up a 2012+ headlight onto my brothers 2007 WR450 and need some help. I just got the headlight parts in the mail. I know the last time I looked at his bike, there were only two wires running to his headlight. The sicass racing high/low switch works just fine, so I'm confused how he is getting high and low beams using only two wires?? Is there another wire going back up to the switch or somewhere that I will need to rewire to the new 3 prong connector? Can anyone help with this?



  • JustG

Posted July 25, 2015 - 06:31 PM

#15

I'll go check wiring now, I can't remember but it was no biggie

f1kwvn.jpg

Edited by JustG, July 25, 2015 - 06:33 PM.


  • JustG

Posted July 25, 2015 - 06:41 PM

#16

90yfix.jpg
348gl6b.jpg
90yfix.jpg
348gl6b.jpg

  • BrianTheDog

Posted July 25, 2015 - 06:58 PM

#17

Awesome! Thanks for the pictures JustG! Looks like I will need to figure out where that third wire should go on his bike. It looked like maybe the sicass kit just ran that wire back elsewhere. I'll definately be using these pics to try and sort that out when I go over there tomorrow. He never wants to ride with me at night because his headlight sucks. I hope I can figure this out.

 

Hey is that one of those quick wire splice clamps you're using? I hate those things. Gave me trouble on my 04.



  • toten

Posted July 27, 2015 - 05:54 AM

#18

I picked up an 07 WR450 headlight to put on my 04, and when I finally got to installing it I found the spacing of the mount tabs on the lower triple is a little different... my triples are RG3 from a 2005 YZ250F but the spacing is right for my stock headlight. Is the spacing on the 07 gen and the 12+ the same? I might have to look for a newer headlight if I have to do some work to make it fit anyway.



  • JustG

Posted July 27, 2015 - 05:57 AM

#19

Awesome! Thanks for the pictures JustG! Looks like I will need to figure out where that third wire should go on his bike. It looked like maybe the sicass kit just ran that wire back elsewhere. I'll definately be using these pics to try and sort that out when I go over there tomorrow. He never wants to ride with me at night because his headlight sucks. I hope I can figure this out.

Hey is that one of those quick wire splice clamps you're using? I hate those things. Gave me trouble on my 04.


Black is just ground. Pair the headlight with the rev2 h4 from advmonster and he will have the most bright brilliant light!

  • msawyer420

Posted July 28, 2015 - 07:21 AM

#20

Im about to install a cyclops 3800 lumen led in mine. Ill let yall knowthe results!




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.