WR dies on idle, starts and works perfect on choke.

6 replies to this topic
  • JACA

Posted February 14, 2015 - 01:27 AM


This is a long story of my WR 450 F 2004 problem. 


The first problem was, my lights went off and no charging. Stator was the problem. I got it regenerated. Everything was fine but suddenly it died again and wouldnt start. I found the problem was a tweaked stator cable. Did that and it lived but another problem occured and is still there... The bike had problems starting. The rpms where very high and when I turned off the choke after heating up the bike it wouldn't idle, helping with throttle made it backfire like crazy and dies... Cleaned the carburator and the problem was still there. Played a little bit with pilot jet and the bike started to fire up on choke like it's supposed to, but turning it off it started to die on idle. It idles strange, it hesitates, little sputter and dies after few seconds. I played with fuel screw and nothing, just the choke is high as &%$#@!.


I ordered JDkit, put it on and The bike fires on choke like new, throttle response is excellent, but still the idle problems when the choke is off... Tried everything, played with fuel screw, throttle screw... Nothing... It just won't idle...


Is this a carburator problem, bad air, electrical problem?? Help please, maybe someone had the same problem. It's 8 months I haven't ridden my WR and I'm frustrated...


Sorry for misspelings, I'm from Poland.

  • GuyGraham

Posted February 14, 2015 - 04:15 AM


Blocked pilot jet in the carb preventing fuel getting getting to the motor on idle

They get blocked with a varnish from dried fuel, and are notoriously difficult to clean

Replace it with a new one and take it from there


The other thing to check is that you have the throttle slide in the right way round and the plate fitted correctly

Edited by GuyGraham, February 14, 2015 - 04:16 AM.

  • ThumpMe

Posted February 14, 2015 - 08:51 AM


+1 on the clogged pilot jet. Also:


 I have an '03 that was doing the same thing and even though I had cleaned out the pilot jet real good it still was hard staring and would occasionally flame out at idle. 


 Not sure if the carbs are exactly the same on an '04 but I believe they are.


 I found that there is a little itty bitty hole in the carb casting on the bottom side and it is visible in about the middle of where the slide sits. It is VERY tiny and goes though the casting and comes into the fuel well where the main jet is located. I took a real small piece of wire and sanded the end with real fine sandpaper (about 400 grit) to sort of knock the edge and any sharp corners off the wire so it will not scratch that hole and poked out that hole...(that is how I found out where  goes). Sort of goes at a little angle so REAL important to not scratch the inside of it! 


 I twisted the wire as I pushed it in to get it to follow the hole because of the angle it runs at.


 I have two wires I use for poking out carbs and idle jets and not sure which one I used on it though. One is .011 and the other bigger one is .017 I think I used the bigger one on that hole but not positive, Still they are both real small wires.


 After that I  have had no issues with carb. Just be sure to either drain the carb if storing bike over Winter or start it up every few weeks and let it warm up or you will be dong this again!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JACA

Posted February 16, 2015 - 08:35 AM


I thought that this could be some dirt in the carburator but as I wrote, I put a new JDkit inside - Pilot jet, main jet and needle. All brand new, so there can't be any dirt inside... The carburator was cleaned before the Kit... My friend has a 2004 WR 450 in his garage and tomorrow I will replace all the things to check which part causes the problem and let you guys know.

  • Krannie McKranface

Posted February 16, 2015 - 03:59 PM


Clear the passage above the pilot jet with fishing line and spray cleaner

  • JACA

Posted February 18, 2015 - 12:31 AM


Ok. Got it. The problem was the air coming through carburator joint. It wasn't screwed enough. Also I had to set the carburator - fuel screw and idle screw. Will put the bike together, test ride it, set the carb perfectly and after 8 months I'm ready to start new 2015 season!! 

  • ThumpMe

Posted February 20, 2015 - 08:25 AM


Clear the passage above the pilot jet with fishing line and spray cleaner

THIS, is a darn good idea!

Would prevents scratching the bore of holes as well as it will be easier to poke fishing line through that angled hole to the main jet well than a wire because I think it would follow the hole better than the wire!! NICE!

One other thing came to mind on this as well. Once years back I had a bike that would work for a while then start goinghaywire, then work for a while more. Turned out when I was re-installing the little o-ring and needle on the air adjustment, I somehow poked a little tiny chunk of rubber off the side of the o-ring and because it was floating around up in the well where the air adjustment needle is, it would move around and sometimes clog up that tiny hole.

It was a real TINY piece of rubber but caused BIG problems and was a real hard problem to locate.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.