LED Flasher Relay Install(Issues)


No replies to this topic
  • elmore55

Posted February 08, 2015 - 02:17 PM

#1

Alright so I've tried almost everything and im stumped, I have a 2 wire (black & red) LED flasher relay that I bought from a local bike shop, so I have my bike completely wired up, flashers work, brake light works, running light works, all of that signals work but do not flash obviously without a relay. I've tried wiring the relay in every which way and every time I've wired it in the way I think it's suppose to goes (turn signal main wire from switch which is powered) and the black wire to ground it pops the fuse on my harness EVERYTIME. I've tried increase the amp of the fuse and that doesn't help either.

Any advice tips or anyone know what to do?!





Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

05 yz450f not fast enough by RedeyeYZ


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  38 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • * * * * *
  • 1 review
  • Last review by Tommyk_55
  • On January 15, 2017
Forums
Photo
Supercross

Wilson the Blue Privateer by jetfuel


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  50 replies
Forums
Photo

BIGBORE FOR YZ450F 2006? by Taattie94


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.