Still won't

4 replies to this topic
  • dweaver76

Posted January 02, 2015 - 05:22 PM


OK valves times, clearance was good.
New plug, verified had good spark.
New fuel.
Carb cleaned and all new jets.

What would you check next?

  • Krannie McKranface

Posted January 02, 2015 - 06:40 PM


What does ' carb cleaned' mean exactly


Unless you did this, you carb is still not ready:




Everything must work

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • dweaver76

Posted January 02, 2015 - 08:03 PM


Went through the link, you posted...tore it back down and cleaned it again.

Seals are all looking good, diaphragm still good and passages clean.


Next idea?

  • bozi

Posted January 03, 2015 - 02:58 AM


I had trouble with my valves not sealing properly so reseated them then had trouble with my timing i checked it 10 times and thought it was ok but had someone take a look at it and he said the timing was out i had followed the manual to the letter. He took the timing chain off set the cams so the lobes were opposite each other and it fired second kick i tried for about three weeks to start it

  • flyandride

Posted January 04, 2015 - 07:57 AM


Check the flywheel key to make sure it's not sheared.  In that case it'll get a spark but at the wrong time.  Also, these engines won't start if loosing compression somewhere.  You need to do a leak down test.   Or the poor mans way.  I've wedged the auto decomp weight to the outside, in the running position.  If you can kick the bike over with the decomp disabled then the bike is loosing compression and won't run.  


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.