Weird smoke/ steam

1 reply to this topic
  • yz45life

Posted December 17, 2014 - 05:55 PM


So I just replace some parts on my 2005 YZ 450 I took off the pipe the water pump and the crank case. I have it all back together now but when my bike starts after about 10 to 15 seconds this white smoke or steam starts showing up at the bottom of the rad. It looks like it is almost coming directly through the exhaust port where the pipe connects to the engine. Anyway if anyone has any advice let me know.oh and also sometimes when I try to start it the kick starter will slip and the pipe will pop. And another thing, every morning there is a little bit of oil on the ground. Don't know if it's related.

Edited by yz45life, December 18, 2014 - 02:49 PM.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted December 18, 2014 - 07:49 AM


Read this.  See if it's your problem.



Related Content


Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.