devol skid plate

Body Guards & Accessories Devol Skid Plate

11 replies to this topic
  • atomic410

Posted November 09, 2014 - 06:31 PM

#1

I bought a devol skid plate for my 2011 yz450.  I really don't see how it fits or installs.  The hook thing on the back doesn't seem to fit anywhere and the front clamp bolts 1 don't seem long enough and two where the hell does the bar that clamps go?  It doesn't seem to fit anywhere between the front of the motor and the back of the frame rails.  I'm totally confused on how this thing attaches.  Has anyone else had this issue?  Does anyone have a picture or instruction links/photos?  I tried to figure this thing out twice now and am still feeling like either it doesn't fit or I'm a total moron. The sticker on the plate has the correct part number.



  • Mtrain730

Posted November 11, 2014 - 03:47 AM

#2

I have the same skid plate on the same bike and didn't have any problems. There is one bolt on the bottom that I believe screws right into the bottom of you engine case and the big t looking thing slides in between your front frame rails and the engine and the skid plate bolts to it.

  • atomic410

Posted November 11, 2014 - 07:40 AM

#3

well that sounds totally different than mine.  Mine has a j style hook on the back held on to the bottom of the plate by 2 bolts and the front if you look down at it is a bar between the engine and frame and has 2 bolts so it makes a II shape.  I'm guessing that mine is mislabeled. 



  • grayracer513

Posted November 11, 2014 - 08:03 AM

#4

The Devol for the '06-'09 models used the same three threaded holes that hang the OEM glide plate in place.  Seems like it should be the same on the newer bikes.



  • atomic410

Posted November 11, 2014 - 08:54 AM

#5

I have one of those also from my 07 its not the same.  The 10+ don't have those tabs welded on the inside of the two front frame rails thus the clamp that is basically a bar and 2 bolts that sandwich the frame rails between the plate and the bar.  But yeah the rear looks like it should mount the same and that's what got me thinking that this plate is labeled wrong since it has the j style clamp mount instead of just a slotted hole like the 07 one.  I sent devol tech assistance a email requesting a photo of the correct one.  I'm guessing this plate got labeled wrong.  



  • atomic410

Posted November 14, 2014 - 12:56 PM

#6

can anyone help me out with a photo of thier 10-12 skidplate?  Apparently devol tech support doesn't email back.



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Mtrain730

Posted November 14, 2014 - 01:11 PM

#7

can anyone help me out with a photo of thier 10-12 skidplate? Apparently devol tech support doesn't email back.

if some one doesn't help you out soon I can later tonight.

  • Mtrain730

Posted November 14, 2014 - 01:17 PM

#8

Mine goes on as you described the front has a bar that goes on the engine side of the front frame rails the skid plate obviously goes on the other side of the frame and you stick two bolts through the skid plate and they thread directly into the bar and sandwich the frame. The bottom just has one bolt. It sounds like you know how it should go on and your probably right it's the wrong one because even with out directions I could figure it out and I'm no mechanic. Lol

  • atomic410

Posted November 18, 2014 - 07:29 AM

#9

if some one doesn't help you out soon I can later tonight.

That would be sweet if its easier you can just email them to me or text them.  I can pm you the info if thats the way you would like to go.  Thanks for your help. I really appreciate it.  



  • Mtrain730

Posted November 18, 2014 - 04:24 PM

#10

That would be sweet if its easier you can just email them to me or text them. I can pm you the info if thats the way you would like to go. Thanks for your help. I really appreciate it.

ok figured you already figured it out you will have to give me at least until tomorrow heading to work and I have to dig it out its not on the bike.

  • atomic410

Posted November 19, 2014 - 06:56 AM

#11

No need to break your back about it since here in the tundra its about 10 degrees out and the riding season is in suspense until either ice or spring.  Thanks again 



  • atomic410

Posted November 25, 2014 - 11:03 AM

#12

not too hyped about devol's customer service...................







Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.