2003 WR450 oil line on left side leaks


2 replies to this topic
  • WR_Bill

Posted October 31, 2014 - 02:02 PM

#1

I changed the oil on my 2003 WR450 and loosened the oil line on the lower left side.  Put it back together using the dowel and the o ring.  It leaked a little, took it back apart and replaced the o ring with one o-ring I had on hand, put it back together  and is still leaked.  So I ordered the OEM replacement - still leaks.  I did not notice any major scratches on the aluminum case of the aluminum fitting.  Should I put some RTV on the aluminum fitting, let it dry and try again.  Anyone have a similar problem? or advice.

 

Thanks in advance

 

Bill


Edited by WR_Bill, October 31, 2014 - 02:42 PM.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • DeepPurplishBlue

Posted October 31, 2014 - 06:40 PM

#2

Had this problem before on my 03... ended up putting two o-rings on it. Hasn't leaked a drop in years.

  • WR_Bill

Posted November 10, 2014 - 06:36 PM

#3

Double o-rings worked great - thanks for the help






 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.