water pump leak? (2003 yz450)


5 replies to this topic
  • soulsedg3

Posted October 23, 2014 - 05:30 PM

#1

So i've been posting a lot, and i apologize guys/gals.    So as you all know i bought a 2003 yz450 recently.   A few misc things here and there have been wrong with it, nothing major i guess (so far).  I had the carb cleaned/rebuilt with a new rebuild kit.   The guy there wired up the pump thingamajig for me.   I'm no longer leaking gas outta carb overflow.   I replaces both the header exhaust gasket and midpipe gasket.  I repacked the silencer.  

 

So before i put gas tank back on, i checked antifreeze level.   And noticed i couldn't see it.   tipped the bike sideways, still nothing.    hrmmm.   So i bought some antifreeze (peak 50/50 diluated). and topped it up.   Upon firing the bike up i noticed it was pissing out the hole just under the water pump quite a bit.    I decided just to go up the road quickly and back to make sure everything was working carb wise etc.  a few adjustments of the fuel screw and i got it idling well, pulling very very hard, and very minimal backfires.   It is still backfiring, initially letting off,  i have no backfire.  after being let off throttle for about 6 seconds from a high rpm, it starts to pop a bit as it gets lower in rpm's in longer successions.   (its pitch black here, and when it does pop, it pitches a 6 inch flame out of the silencer.) not sure if this seems right or not, but it works for me i guess.   no bog hitting throttle, no hesitation at all.   i pulled in the hotstart, while idling and idle went very high, which seems like thats working well =)

 

 

Anyways, after going up the road and back about 4 times. i stopped and noticed the water pump hole was no longer spewing fluid.    Does this mean the seals are going, and once they warmed up, they started sealing properly?

 

from the few posts i read about other bikes, it seems thats the sign your seals are going in water pump.  guessing same holds true for this bike?  I at least wanted to get in a ride or two on this darn thing.  *sigh*

 

oh, and once i put it back in my garage, i took the airfilter off to oil it for my ride on sunday.   there was a red UNI filter, covering a yellow filter.  So it was two airfilters technically.  over the airfilter frame thing.  Is this correct?  Seems to me, it should only be the skeleton frame for the airfilter and a single filter only.  not dbl?

 

Sorry for the multiple questions.  

 

IMG-20141023-00432_zpsb9ea254a.jpg


Edited by soulsedg3, October 23, 2014 - 06:26 PM.


  • writebrian

Posted October 24, 2014 - 12:34 AM

#2

Yes the weep hole indicates your water pump seal is going. Easy fix, with plenty of help on Youtube. I did it myself and I am not a 'wrencher' by any means. Took about an hour. Be sure and check the shaft for grooving also. It was pretty bad on my buddies 2003 bike that I fixed. Parts (even OEM) are WAY cheaper on eBay then at the dealer!

 

You should have only ONE air filter. You could be seeing the inner and outer elements of the same filter separated. Buy a new one.


Edited by writebrian, October 24, 2014 - 12:35 AM.


  • Slow and Jerky

Posted October 24, 2014 - 04:06 AM

#3

That particular filter is supposed to have a removable inner and outer I had the same one on my 06 when I got it. Don't toss the outer filter. It does sound like your water pump is going but, if it has been sitting a while I wouldn't be to quick to change it out. If it leaks the next time you start the bike (when it's cold) I would change it, but if it doesn't leave it alone but keep an eye on it. You should get in the habit (if you don't already that is) of checking your coolant level before each ride. These bikes don't have any sort of an overflow bottle,  so if you boil over even a little (which is common on slow, tight riding) you lose fluid.



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • soulsedg3

Posted October 24, 2014 - 04:23 AM

#4

Awesome. Thanks guys....these forums are the best. I apologize for all the noob questions as im just getting back into tinkering and riding after a 15 year hiatus lol.
Oh. Slow and jerky. Do i oil both the inner and outer filter?

  • Slow and Jerky

Posted October 24, 2014 - 04:31 AM

#5

Yes, just make sure you don't over oil them. The oil should be evenly dispersed but not dripping, put a little on at a time and then squeeze the filter (don't twist on it) to spread the oil around. I do put it on pretty heavy and the part that seals to the air box though.



  • grayracer513

Posted October 24, 2014 - 07:25 AM

#6

Water pump repair:

 

http://www.thumperta...0-coolant-leak/







Related Content

Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.