Still can't figure out what's wrong!


2 replies to this topic
  • AndrewAndrew213

Posted September 04, 2014 - 06:34 PM

#1

Hey guys a couple weeks ago I put a thread on here about my bike bogging and back firing, so I replaced the fuel pump and it seemed to help but it started happening again so I ran injector cleaner and it finally shut off and wouldn't start(I was in the woods quite far) so I replaced the injector still no luck, my timing is correct (I believe all the dots on the cams are where they say to be in the manual) when I replaced the injector it was hard to start but it did and would non stop backfire I have no idea what to do

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • -texas2stroker-

Posted September 08, 2014 - 11:29 PM

#2

With the newer thumpers, you have to orient the cams as per the manual. THEN you have to do a pin count. You'll have to count the pins from one reference point to another. You'll find that in the manual. What are you working on?

  • grayracer513

Posted September 09, 2014 - 06:50 AM

#3

THEN you have to do a pin count. You'll have to count the pins from one reference point to another. You'll find that in the manual.

 

You never have to do a pin count, and it's not in the manual that way.

 

Take the bike to a shop or find a buddy with the GYT-R tuner and interrogate the CDI for trouble codes to begin with. 







Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.