600(642) clutch slipping?



1 reply to this topic
  • PismoRat

Posted January 27, 2004 - 11:39 PM

#1

I just rebuilt the 600 to a 642 w/ a hotcam. It already had race clutch springs in it, and the clutches looked good. The adjustment is good, but after riding 300 hard miles over a couple weekends, it feels like it is slipping a little. Could it have too much power, or what is the problem, any good replacement parts for big bore bikes? :)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • MotoChris521

Posted January 28, 2004 - 06:07 AM

#2

Replace the friction plates.They might"look"good,but did you measure the thickness?I re-used the steel plates in mine. :)





Related Content

Forums
Photo
Supercross

Supercross Preview 2017 Part 1: Championship Contenders by Chris Cooksey


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  186 replies
Forums
Photo
Washington

Cle Elum Sunday 5/29: Looking for dual sport tips by TigerTanker


Dirt Bike   Dirt Bike Regional Discussion   Northwest
  • Hot  32 replies
Forums
Photo

Wiseco 101MM Spark Knock Low Engine Temps by imandrewparks


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 9 replies
Forums
Photo

2015 XR650L Squeaking noise by Crayjay


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies
Forums
Photo

DirttyPig 2005 Xr650l Prroject! by braapmebb1moretime


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 22 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.