07 yzf 450 blowing vavle cover gaskets


2 replies to this topic
  • Shawns07

Posted August 17, 2014 - 09:23 AM

#1

Hi every one I just picked up a 07 yzf 450 very nice bike. Starts every first to second kick idles runs great. I rode it for bout an hour, wile i was at wide open throttle the valvecover gasket blew out. Replaced with oem gasket checked to make sure nothing was in breather line, I got it back together and rode it for 5-6 hours, wen I got back home I noticed that air/oil was weeping threw bottom of vent hose, so I cleaned it Up and put in shed. The next day I took it for ride up the road and back, on the way back I was about quarter throttle and the valve cover blew again? Bike still starts and runs great I don't get it any help would be appreciated.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Shawns07

Posted August 17, 2014 - 10:21 AM

#2

Oil is at right level to

Edited by Shawns07, August 17, 2014 - 10:39 AM.


  • Shawns07

Posted August 25, 2014 - 06:56 AM

#3

Pulled top end off there were no cracks in piston or head? Anything els I should be checking? I noticed that piston is a high comp piston could that be the problem? I'm ordering new stock piston and gaskets hopefully this fixes problem





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.