2010 yz450f bog/backfire


18 replies to this topic
  • AndrewAndrew213

Posted July 24, 2014 - 07:29 AM

#1

Hi guys, I have a 2010 yz450f I bought it about a year ago and had no problems until now once during a race I was going up a hill and I wrenched the throttle and it bogged. Iv never had that problem before not thinking anything of It I finished the race. But once I got it home I started to ride around my house and it start to bog and back fire so bad I barely made it home, I ran fuel injector cleaner and it seemed to help but the very next tank of gas after the cleaner it started to backfire and shoot 4 inch flames out the exhaust, I only have this problem when the engine gets hot I just have no idea where to start
All help is greatly appreciated

  • grayracer513

Posted July 24, 2014 - 08:26 AM

#2

The first thing to do would be to access a GYT-R tuner tool, or visit a shop, and see if the ECU has a problem code stored.  If that's all clear, I'd have a look at the fuel filter in the tank. 



  • AndrewAndrew213

Posted July 24, 2014 - 10:49 AM

#3

Thanks a lot I'll try that out and let you know how that goes

  • YzCas

Posted July 24, 2014 - 11:35 AM

#4

Hi guys, I have a 2010 yz450f I bought it about a year ago and had no problems until now once during a race I was going up a hill and I wrenched the throttle and it bogged. Iv never had that problem before not thinking anything of It I finished the race. But once I got it home I started to ride around my house and it start to bog and back fire so bad I barely made it home, I ran fuel injector cleaner and it seemed to help but the very next tank of gas after the cleaner it started to backfire and shoot 4 inch flames out the exhaust, I only have this problem when the engine gets hot I just have no idea where to start
All help is greatly appreciated

i know this sounds stupid when is the last time you changed the spark plug.

  • AndrewAndrew213

Posted July 24, 2014 - 11:36 AM

#5

I never have

  • AndrewAndrew213

Posted July 24, 2014 - 02:20 PM

#6

I tried the plug, although it needed to be replaced badly, it didn't work, went for a ride and in 3rd it started to bog really bad pulled in the clutch boom shut off, dropped it into 1st and dumped it and it started rode it home before it shut off again
I'm thinking it's a fuel starvation issue I'm gonna look into it tommorow

  • leo 450yfz

Posted July 24, 2014 - 11:32 PM

#7

I tried the plug, although it needed to be replaced badly, it didn't work, went for a ride and in 3rd it started to bog really bad pulled in the clutch boom shut off, dropped it into 1st and dumped it and it started rode it home before it shut off again
I'm thinking it's a fuel starvation issue I'm gonna look into it tommorow

 

 Mine was falling on it's face too. Changed the fuel pump first, then the injector, because I smelled gas in the oil. Then I realized that I had no freeplay in my throttle, and thought that adjusting it fixed it. None of that did anything really. I bought GYTR ignition tool, plugged it in. First thing it gave me was code 22. Air temp sensor fault. It was reading -27 degrees celcius as well. Went to check the sensor, as soon as I pulled off the air box and unplugged it, I noticed that one of the wires on the plug wasn't making a contact. Cleaned and reconnected the wire - no more problems

 

 . I don't know why it was showing -27 with the sensor disconnected, but it being fuel injected, it would dump tons of fuel to compensate for that kind of temp, causing all my problems. Bottom line, that might not be what you have. But having that GYTR tool even for diagnostic only, is handy as hell! If anything, take it to the dealer, and see how much they would charge you to use theirs. Local place told me I could play with the one they had for 20 bucks, but I figured it couldn't hurt to own one.

 

 Good luck.



  • AndrewAndrew213

Posted July 25, 2014 - 04:50 AM

#8

Thank you, bikes are getting way more advanced, the next thing you know there will be a check engine light on them hahaha

  • YzCas

Posted July 25, 2014 - 09:03 AM

#9

I tried the plug, although it needed to be replaced badly, it didn't work, went for a ride and in 3rd it started to bog really bad pulled in the clutch boom shut off, dropped it into 1st and dumped it and it started rode it home before it shut off again
I'm thinking it's a fuel starvation issue I'm gonna look into it tommorow

If they weren't injected in 2010 you doesn't get this from me I have an 03 I keep for sentimental value it don't hurt that it starts first kick either oh and is fast as beck still.
find the bowl over flow hit it in the hose real quick with air hose.
That's if carbonated.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • YzCas

Posted July 25, 2014 - 09:05 AM

#10

Thanks a lot I'll try that out and let you know how that goes

I'm sorry after going back it's not carburated. SORRY.

  • AndrewAndrew213

Posted July 25, 2014 - 09:10 AM

#11

Well it was the original plug and needed to be replaced ImageUploadedByThumper Talk1406308179.763036.jpg

  • AndrewAndrew213

Posted July 27, 2014 - 05:37 AM

#12

So after changeling the plugs and checking the valves I gave in and dropped the money on a gytr tuner it should be here tues I'll keep you guys posted on what fixes my problem

  • AndrewAndrew213

Posted July 29, 2014 - 06:31 PM

#13

I got the tuner today. and after playing with it, it did not show any codes for any sensors. so i am thinking its the fuel pump or a clog in the injector. i didn't need to spend the money on the tuner but at least i have it now. i just hope i can figure this out! I am dying to ride my baby!!



  • leo 450yfz

Posted July 29, 2014 - 11:56 PM

#14

I got the tuner today. and after playing with it, it did not show any codes for any sensors. so i am thinking its the fuel pump or a clog in the injector. i didn't need to spend the money on the tuner but at least i have it now. i just hope i can figure this out! I am dying to ride my baby!!

 

 Sucks you didn't find the exact problem yet. I'd try the pump first. Since it's cheaper, the one I got off the ebay ran me about 30 bucks shipped, and came with the filter, it's been working just fine for about 20 hours now. Maybe try the injector after that. If you don't want to waste a 100 bucks trying to just confirm it, pm me. I could send you my spare one to try see if that's what it is if you cover the shipping there and back.



  • AndrewAndrew213

Posted July 30, 2014 - 03:56 AM

#15

Thanks you for your help, I'm gonna order the fuel pump today. I'll keep you posted

  • AndrewAndrew213

Posted July 30, 2014 - 04:03 AM

#16

Also do I need to buy the entire assembly, Or just the pump? the assembly is like 200 just the pump is like 30 is it possible to just replace the pump?

  • leo 450yfz

Posted July 31, 2014 - 08:44 PM

#17

Also do I need to buy the entire assembly, Or just the pump? the assembly is like 200 just the pump is like 30 is it possible to just replace the pump?

  You can replace just the pump. Make sure that the 30mm replacement you order comes with a replacement black fuel line tube, I had to cut my old one off. The new one that came was thicker and came with 2 small hose clamps, only tricky part was tightening them under an angle, where they didn't get in the way when I was putting the assy back inside the tank. Otherwise it's a fairly simple process. This thread http://www.thumperta.../#entry10702600 that's in the sticky, should give you a general idea.



  • AndrewAndrew213

Posted August 02, 2014 - 02:30 PM

#18

Got my fuel pump today! I put it in and all the big/backfire I was having seemed to go away! As of right now I'm gonna say it's fixed if I get the problem coming back on a longer ride I'll let you know Thank-you for all your help it's greatly appreciated

  • AndrewAndrew213

Posted August 24, 2014 - 12:12 PM

#19

So I replaced my pump and it seemed fine for a while and today I got that bog back and I'm not sure why the fuel pump and filter is brand new! I'm considering buying the injector but if it dosnt work I'll be out the 100 bucks





Related Content

Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F


Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
Forums
Photo

First Hare scramble tips by dhend8


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.