What part failures have you guys had ????



22 replies to this topic
  • Looped_Out

Posted January 19, 2002 - 03:30 AM

#21

When I bought my 99 400, it was 3 months used. It's my only bike at the moment and I ride it a lot, year round. Mainly it's bars, tires, chain, sprocket, grips and normal wear stuff. However I have replaced my fork seal and bushings, I'm on my 3rd fuel tank, 2nd throttle cable, and rebuilt my muffler several times. The weirdest was the slide in the carb developed a huge crack in it. This is the small aluminum piece on the front of the slide (nearest the cylinder). Once I replaced it ($75!!), it quit backfiring and ran like new, along with the new topend of course. Every year I keep thinking about a new bike, but why? I just race local MX for fun and trophies, and the it's not the bike's fault if I don't go fast.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • dan_Rekito

Posted January 20, 2002 - 05:47 AM

#22

Fork seal wipers Im gonna check that this weekend when I change the fork oil . No riding this weekend we just got 8 inches of snow!

  • freestyle111

Posted January 20, 2002 - 01:54 PM

#23

the factory parts that have failed on me are:my right arm,left wrist,both knees,6 or 7 ribs,collarbone twice,lower back and i wore out my tail bone within first 500 miles.im trying to get kaiser hospital to sponser me.

[ January 20, 2002: Message edited by: freestyle111 ]





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.