2002 YZ426F compression issue?

3 replies to this topic
  • ipsullivan

Posted June 05, 2014 - 05:10 PM


My buddy just bought a 2002 yz426f this week. It ran fine when he bought and this morning. All of the sudden he said it stalled and couldn't get it started. He took the bike to his dad's auto shop and the mechanics there decided to pull the spark plug to test for spark. He said the bike lost compression somewhere in between those events. And won't start now.

It can be kicked over without the compression release. My thought it the spark plug didn't get tighten properly, therefore losing compression. He said the bike wouldn't kick without the compression release prior to taking the plug out.

The previous owner had the top end done with not many hours on it.

Any thoughts? I didn't have time to check it out for myself today.

I own a 1998 yz400f and wouldn't even consider kicking it over without the compression release.


  • anthonyvc

Posted June 05, 2014 - 05:22 PM


Check timing mine did same thing and one tooth slipped on my intake cam

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted June 05, 2014 - 06:55 PM


A rebuild without receipts is just a promise.

  • ipsullivan

Posted June 06, 2014 - 01:19 AM


Dang it, just realized I put this in the wrong forum. Any way it can get moved to the yz section?


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.