Cooling system building lots of pressure


1 reply to this topic
  • msliker22

Posted May 15, 2014 - 11:10 PM

#1

I got a 07yz450f and the guy that owned it before me busted the waterpump cover and then instead of buying a new one he siliconed the crap out of the busted one and when I got the bike first thing I did was replace the pump cover and the gasket and the y pipe an gasket that connect to ure hoses that go to ure radiators so yesterday I took the bike up an down the road for the first time and about 3 minutes into the ride coolent started spraying from the cap on top of the radiator so I immediately shut the bike down and pushed it home and put it in the shop for the night then when I went to check it out today and I pulled the cap off and there was still pressure built up it also seemed to be leaking from the bottom of the crank case had anyone had this issue maybe it's clogged up somewhere I'm at a loss of what's happening here any advice would be greatly appreciated

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • msliker22

Posted May 15, 2014 - 11:12 PM

#2

Also when I start the bike and run it for about 10 seconds I can spit on the pipe. And it sizzles right off not sure if the 4 strokes generally get hot that fast or what thanks guys





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.