wr450 ignition switch

3 replies to this topic
  • topp38

Posted May 09, 2014 - 01:45 PM


Hi all ive a wr450 and there a problem with ignition switch...i put it on and bike fires but wont start..then the light on the swith will come on and it starts...bud if the light doeasnt show up it just turns over without starting...its a bloody headache...can i bypass tge ignition switch so its on all the time...looked for a new switch but tgere all in the us..and im in scotland...any help would be great thanks

  • flyandride

Posted May 09, 2014 - 06:22 PM


I doubt that it's the switch.  You need to pull apart every electrical connection and see if you find anything corroded or wet.   You could cut the wires to the switch and connect the red and brown, they turn on the power.  The other 2 are for the red light, don't connect them together.  

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • topp38

Posted May 09, 2014 - 11:50 PM


Thanks for tge reply flyandride...its very strange indeed..it will fire with switch on..but it wont start..when tge red light comes on it starts...what the hell is going on??

  • topp38

Posted May 11, 2014 - 11:45 AM


Found tge problem..brocken wire on the plug cap...thank god it sorted


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.