2003 WR450F Accelerator Pump Weak Stream.


6 replies to this topic
  • tcashion93

Posted April 12, 2014 - 12:24 PM

#1

I've been thru all the steps/mods of the bog issue and still have a weak stream out of the AP nozzle... I've done the o-ring mod put in a new diaphram and cleaned all the jets etc. I noticed there is fuel coming out this hole when the AP pump is triggered I just need to know if that is some sort of overflow (or normal)?... I thought it might be why the stream is weak, losing pressure here? Thanks for the help I'm a nooby with this style of carb but am not mechanically challenged just bear with me. THANKS IN ADVANCE!

Attached Thumbnails

  • 1397334267184.jpg


  • Krannie McKranface

Posted April 12, 2014 - 01:08 PM

#2

You need to service the apump system

Clean the apump passages, and make sure the check ball-bearing is not stuck

       - better yet, upgrade to the 2008 crf450r version: there is a kit for this on crf'sonly.com

Diaphragm: must be pilable and have the short rivet

No corrosion anywhere

Leak jet: must have 50 or smaller to get a properly filled up cavity

Linkage spring: if it is stock, it will never squirt right. You need to wire it shut (mickey mouse version) or better yet replace the spring with a merge racing or tokyo mods spring.

You might also soak the brass nozzle in some solvent: I used a little cap over the nozzle and squirted PB blaster underneath. You can also try a piece of wire from a wound guitar string.



  • Krannie McKranface

Posted April 12, 2014 - 01:10 PM

#3

Looking at the picture again, you are showing squirt with the slide down.

That is not right.

I think you nozzle is clogged and it's having a hard time 'emptying' the apump reservoir. 



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tcashion93

Posted April 12, 2014 - 01:16 PM

#4

I'm positive all the AP passages are clean and clear. I really cant afford to buy an upgrade. I have considered grinding down the long rivet on the diaphram but wanted to see why the fuel was coming from that specific hole, or (if that was normal)? I can troubleshoot from there.

  • tcashion93

Posted April 12, 2014 - 01:18 PM

#5

Oh and as for the timing with the slide down. I dont have the throttle cable hooked up so I just manually pushed the AP lever and it is both a short and weak stream.

  • William1

Posted April 13, 2014 - 02:24 PM

#6

Inspect/test the check valve in the float bowl.

 

You cannot fully operate the AP how you did. Rotate the throttle wheel quickly.



  • Krannie McKranface

Posted April 13, 2014 - 07:49 PM

#7

You need to service the apump system

Clean the apump passages, and make sure the check ball-bearing is not stuck

       - better yet, upgrade to the 2008 crf450r version: there is a kit for this on crf'sonly.com

Diaphragm: must be pilable and have the short rivet

No corrosion anywhere

Leak jet: must have 50 or smaller to get a properly filled up cavity

Linkage spring: if it is stock, it will never squirt right. You need to wire it shut (mickey mouse version) or better yet replace the spring with a merge racing or tokyo mods spring.

You might also soak the brass nozzle in some solvent: I used a little cap over the nozzle and squirted PB blaster underneath. You can also try a piece of wire from a wound guitar string.






 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.