07 WR 450f Starter issue?


2 replies to this topic
  • 808flyer

Posted March 18, 2014 - 10:55 PM

#1

Recently replaced a starter and worked well went for a half day ride then two days later bike won't start just clicking sound. Battery checked good. I replaced the starter solenoid and no change still just a click sound. Any similar stories or incidents like this? Is there something else I should be looking at? Thanks in advance.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • stevethe

Posted March 19, 2014 - 05:45 AM

#2

How good is the battery it should be 13 volts or higher. Did you put a new starter in her.

 

 Don't jam the cover on with the gears in it, It could jam the armature. The best way to put a starter in is to remove the gears from the small starter case and then install.



  • 808flyer

Posted March 19, 2014 - 08:28 AM

#3

Battery checked good. Yes I did put a new starter in her. I will check if the gears jammed the armature. It did work for a half day ride with probably 15 or so starts. Thanks for your input.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.