2007 YZ450f need help



1 reply to this topic
  • sturgill_252

Posted March 10, 2014 - 07:34 PM

#1

THis is my practice bike. I bought it off of a friend and he had it and he overheated it. the bike was low on antifreeze but was not completely out. i bought the bike put a new top end and timing chain in it and soon discovered that the exhaust cam had a slipped sprocket. I bought a used exhaust cam and installed it and within 7 kicks the bike cranked. I rode it for a day and then got it back out to ride again and it cranked i warmed it up then shut it off and went inside to get my gear on. I came outside cranked it and heard a grinding noise in the topend and it died. I cranked it again and heard the same thing and it died again. I tore the bike down and discovered that it had another bad exhaust cam. I have no idea on what could cause this? Maybe the cam saddles? is there a way to fix it? I need help



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted March 11, 2014 - 07:27 AM

#2

Check the clearance in the cam saddles as shown in the manual.  If there's a problem, EDCo or Millennium Technologies can redo the cam bores.  







Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.