2010 yz 450 acceleration problem



14 replies to this topic
  • korich1

Posted March 03, 2014 - 01:29 AM

#1

So here is my situation I raced a hare scramble this weekend a hour and half, bike ran great on the 2nd lap only on full acceleration the bike would not run, backfires and sounded dead,it did not stall and would idle and ran on 1/4 throttle, but anymore throttle then that would would not rev up sounded like you hit the kill switch but with a backfire. It stalled once because I didn't get out of the throttle fast enough and I started the bike right back up and ran fine, it was almost like the ecm reset itself, about 15 minutes or so the bike went back to same thing no acceleration, and this happened 1 more time I wrecked and restarted the bike and it ran fine for another 10 minutes or so, when I finished the race it was acting up again so I hooked up my gytr power tuner to see if there was a code and it still showed 0 on the error code, any help would be great thanks

  • Krannie McKranface

Posted March 03, 2014 - 06:28 AM

#2

2. Do you filter your gas before putting it in the tank?

3. Have you serviced the fuel pump filters?

4. Have you service the FI injector nozzles?

5. Do you treat your gas to prevent Ethanol corrosion?



  • korich1

Posted March 03, 2014 - 07:17 AM

#3


I just got the bike have checked the filters etc, the weird part is it has no problems for 15 minutes or so then starts acting up. Almost like ecm forgets what it's doing, because once it shuts off And is restarted it will act normal again, was just trying to see if anyone else had a bad sensor, fuel pump, ecm etc thanks



  • grayracer513

Posted March 03, 2014 - 07:37 AM

#4

Could also be something as simple as an obstructive gas cap vent.  Next time it acts up, instead of restarting, crack the cap loose for a second or two and see if that clears things up.

 

As far as the sensors go, it's possible that one is acting up.  Download a manual and run the tests described there.  If you can get your hands on a GYT-R tuning scanner, you can pull problem codes from the ECU also.

 

Manuals:

http://www.yamaha-mo...uals/index.aspx

 

http://www.yamahaown...ook.com.au/?r=0



  • korich1

Posted March 03, 2014 - 08:39 AM

#5

Thanks I will use the link, I do have a gytr power tuner but no codes come up and everything appears ok. Once again thanks

  • WYO522

Posted March 03, 2014 - 08:50 AM

#6

Really sounding like a fuel pump. I never had an issue with mine, however, two of the guys I ride with have 2010's. All of them have had fuel pumps go bad with identical symptoms to yours.


Edited by proclimber522, March 03, 2014 - 08:53 AM.


  • grayracer513

Posted March 03, 2014 - 09:15 AM

#7

Definitely fuel delivery related by the sound of it. The filter is "non-serviceable", but that depends on how determined you are (note the title of the linked thread):

 

http://www.thumperta.../#entry10702600



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • WYO522

Posted March 03, 2014 - 10:31 AM

#8

Definitely fuel delivery related by the sound of it. The filter is "non-serviceable", but that depends on how determined you are (note the title of the linked thread):

 

http://www.thumperta.../#entry10702600

 

This is great info! The thread ends without saying if cleaning the filter worked though? For how long? I am now going to look into possibly replacing my OEM fuel line with soft hose and putting in an aftermarket filter. I think doing this will prolong the fuel pump life. Hmmmm :thinking:



  • korich1

Posted March 03, 2014 - 12:03 PM

#9

Just want to say thank you for the info and help!

  • grayracer513

Posted March 03, 2014 - 12:12 PM

#10

This is great info! The thread ends without saying if cleaning the filter worked though? For how long? I am now going to look into possibly replacing my OEM fuel line with soft hose and putting in an aftermarket filter. I think doing this will prolong the fuel pump life. Hmmmm :thinking:

 

A filter in the line past the pump won't help the pump any, but the injector may like it.  If the filter at the pump plugs up and restricts flow to it, the one downstream will make no difference.



  • WYO522

Posted March 03, 2014 - 12:38 PM

#11

Right. Dunno what I was thinking? I guess in my mind I was picturing the fuel pump being external. Brain fart! :wacko:



  • korich1

Posted March 03, 2014 - 01:07 PM

#12

ImageUploadedByThumper Talk1393880699.380566.jpg

Thanks for the info went onto eBay and bought both pump and filter couldn't pass them up for 35 dollars.

  • Megatron

Posted March 03, 2014 - 01:32 PM

#13

II think greyracer idea about the airflow thru the gas cap sounds like your issue. Same thing happens to me if I have my bike opened up a bit, like rippin down a gravel road, all of a sudden the bike starts acting like it has low fuel and the power sucks. Defiantly check that one, it won't cost you anything

  • korich1

Posted March 03, 2014 - 02:19 PM

#14

Yes for sure, I have a 09 also and I will take the lid of the stock tank with breather and try that also, thanks everyone

  • bsam450

Posted May 20, 2014 - 03:02 PM

#15

Recently having the same low end bog and back fire. Checked valves, good, air cleaner, good, sensor in air box, good. fuel injector cleaned and re-installed, took the tank apart and cleaned filter like everyone else. Found replacement submersible fuel line at Napa. Tygon Tubing, part number 7-08152, 1/4" line. $3 a foot. Runs like brand new again. Thanks for all the help!







Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.