water pump


1 reply to this topic
  • etuke

Posted February 23, 2014 - 09:28 AM

#1

Is it normal after the bike is laid up for the winter for the pump to weep a lil bit?Started my 07 yz450 today since last september just to try her and after it was running a few seconds a lil bit of antifreeze came out around the pump,I couldn't see if it was the vent hole but it dripped from the bottom bolt which I think is the drain bolt.I checked the rads and they are full.Just wondering if it a common thing or am I gona have pump seal problems later.



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted February 23, 2014 - 05:10 PM

#2

It can happen. If it continues, you'll need to fix it.





Related Content

Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Forums
Photo

First Hare scramble tips by dhend8


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.