WR 400 Clutch issues and questions

No replies to this topic
  • mikseven

Posted February 08, 2014 - 06:49 AM


Hy everybody,
I present myself. I'm Mik, writing from Italy.

I own a WR400 2001 and I'm very happy with it.

I'm going to race in the Italian Motorally Championship this year.

ImageUploadedByThumper Talk1391870066.017139.jpg

Let's go to the question.

I got this bike last year.
It has Rekluse Z Start mounted on.
i've disinstalled the Rekluse now because the clutch boss is broken.

Now, I can see this situation.

1. The Rekluse Clutch Boss seems to be a Yamaha Part modified by Rekluse. Somebody can confirm that?

2. Intalling the stock clutch i see a little wear on the push rod and on the actuator. I have to install a 1/16 shim in order to get the correct tension. I see that Many people found a bearing ball. Is not my case. Is this a common problem?

3. I see that the 426 clutch is totally different. It has 6 springs and 9 friction plates. Is that clutch compatible with 400? I can buy a complete clutch including basket, boss, plates and pressure plate.

Thanks in advance for your help



Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.