Headlight Dims when Revved up

2 replies to this topic
  • Riggsy08

Posted February 06, 2014 - 02:12 AM


I have a 03 WR450f, the headlight dims when you rev it, blinkers only work when you rev it and horn sounds like it is underwater or doesn't sound at all. I was given a box with all the blinkers etc. inside when I bought the bike second hand. It has a brand new battery but is only running at 12.2 v at idle and max 12.5. Sometimes the starter motor clicks like the brushes are worn. Any ideas?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • SurfaceToAir

Posted February 06, 2014 - 05:33 PM


Sometimes a bad ground will cause those symptoms.  Maybe start with the battery cables, and then work you way back from there.  Not sure how the PO wired in your kit, but you might also disconnect it ( if possible ) to see if its affecting the other stuff.

Aside from that, ( and I've not had to deal with this myself, so I will really defer to others who have )- you might check the stator to see if its on the way out.


Good luck-


  • still2smokin

Posted February 06, 2014 - 10:58 PM


Regulator/Rectifier needs to be replaced.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.