Carby Troubles



4 replies to this topic
  • stonker426

Posted January 03, 2002 - 02:10 AM

#1

I am currently in the process of performing the BK carb mod I found on this site. The only problem I seem to have is that the cam for the accelerator pump does not even get close to the stop when the throttle is opened. I have stripped and cleaned the pump,diaphragm and pushrod but the action is the same. The pump spray length without the mod is .6 second, this makes me wonder if the pump is working correctly. My question is does the pump cam contact the lug on the carb even if the bike is not running or does it require some sort of vacuum when running ??? I have checked out all the photos from motomans site and the mod looks straightforward but I can't see it helping if the cam is not travelling all the way. My bike is a stock '00 426 apart from a WB e-series muffler.
Any help would be greatly appreciated. Thanks

  • smrmx

Posted January 03, 2002 - 02:48 PM

#2

The lever on the carb works backwards from what you think. the olny time it contacts the screw is when the throttle is closed and moves away from it when it opens.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • bbeakley

Posted January 04, 2002 - 11:26 AM

#3

I don't have pictures of mine, but the BK screw is not very far from the cam when the throttle is closed. I would guess that it's about a 1mm gap, maybe less. The cam rotates toward the screw and hits it when the throttle is opened. The gap between the screw and the cam in the closed position is what modulates the spray duration. Larger gap = longer spray and vice versa.

I'm not sure I'd worry too much about it with a 0.6s stock spray duration though, you may not need this mod at all. Most have found that 0.3s-0.5s is the sweet spot. That plus setting the timing delay such that the spray misses the slide should cure the bog.

If you'd like I can take some pictures tonight and post them.

  • Hick

Posted January 04, 2002 - 02:10 PM

#4

Stonker,

BTW what is a Stonker??

The pump operates solely on the energy of two springs. One is wrapped around the slide pulley and is released when you open the throttle, pushing the cam down (or clockwise). The second is the one you found inside the pump housing when you cleaned it. It pushes the diaphragm back up when you release the throttle (and thereby rewind the first spring) and refills the pump. So the pump should work identically regardless of what the bike is doing or whether the carb is even installed.

Your bike should have a much longer pump duration, I never bothered with the timing thing but I think most guys get around 3 seconds on a ’00 426. Is the push rod installed correctly? It needs to be pressed, pretty forcibly, into the little “socket” in the black plastic actuating arm. Looking at the cam thing from the side you can see a little notch and a cavity that exists behind it. The little “nub” on the end of the push rod needs to be all the way inside that cavity.

Or maybe somebody replaced the stock pump cover or modified the pump diaphragm. There is an aftermarket pump cover, R&D lightning (search on that term and hang on to your processor), and there is also optional pump diaphragms that the previous owner could have (wisely) swapped in place of stock parts. I’ve never seen the R&D product up close but I imagine it is easily identifiable.

If all the above fails I think the next thing you need to do is see if the diaphragm is bottoming on the pump cover. That could be tricky, but not if you have a pair of calipers and the carb is off the bike.

Hope this helps.

[ January 04, 2002: Message edited by: Hick ]

  • Thumpologist

Posted January 06, 2002 - 06:11 PM

#5

I am having the same problem. When I did the BK mod the acc. pump would rotate all the way to the stop. Now after reassembly the acc. pump does not move to the stop. All I can guess is while moving the carb around when it was off the bike some dirt got moved around inside. Any suggestions???





Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.