08 Running high rpm

5 replies to this topic
  • Pfrimweiser

Posted December 29, 2013 - 05:52 PM


Recently got some decent weather to take the bike out after cleaning the carb, adding a larger starter jet, fuel screw and radiator guards. When I started it, it was running like I was constantly twisting the throttle. I didn't even have to give any gas to take off. Is there something that would cause this. I checked where the throttle cables go and they look like they have some slack so that can't be it. Could it be the fuel screw or even my hot start plunger? Help is greatly appreciated. 

  • Krannie McKranface

Posted December 29, 2013 - 06:26 PM


First off, define 'cleaning the carb':


-did you remove the slide? If so, did you remove anything other than one allen screw holding it to the shaft linkage?

- did you lube the hot start cable and plunger after 'cleaning'?

- is the slide plate installed 'hole down'?

- did you adjust your fuel screw using the 'william' method?


Hot start plunger corrosion is very common....causing the plunger to stick open and cause a fast idle.

  • Pfrimweiser

Posted December 29, 2013 - 07:15 PM


Cleaning: Noun: LOL I took the carb apart and sprayed it with carb cleaner then blew it out with compressed air. I didn't spray any rubber items like the O-ring around the slide.

I only took the one screw out which held the slide in, but I also took the needle out to make sure there was nothing going on with it. 

What is the "william" method?

I will check my hot start plunger, but when I last had it off it looked good. 

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Pfrimweiser

Posted December 29, 2013 - 07:30 PM


Is there a way to grease or lube the hot start plunger?


  • Krannie McKranface

Posted December 29, 2013 - 07:38 PM


Is there a way to grease or lube the hot start plunger?

The plastic nut that attaches the cable to the hotstart is very fragile, and cracks, usually from turning the carb sideways to work on it.

  • Pfrimweiser

Posted December 30, 2013 - 03:48 PM


I just finished tearing down my bike and replaced the plastic nut with an aluminum pro circuit one. I appeared to be stripped on the threads from the last time I took it apart. I also discovered that when I installed my flex jet fuel screw that the plastic sleeve was chewed up and I found pieces up by the spring inside the carb (I should have installed it with the carb off the bike.  :banghead:  I replaced that with a normal fuel screw that I can still adjust. 


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.