07 WR450 Unsolvable :(

22 replies to this topic
  • Team_Oatmeal_Pie

Posted November 30, 2013 - 10:17 PM


dont forget to rule out a faulty kill switch-  had a random short with mine, lot of time looking at other sources of the problem, before finally figuring it out.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • westdot

Posted March 16, 2014 - 10:53 PM


OK so after much time and confusion the bike is fixed :( i sent it in to the shop and they could not find out what was wrong either so a friend of mine collected the bike and fixed it in 30mins :( haha.. hopefully this will help someone else somewhere.. Basically he noticed 2 hair line cracks on the ignition coil(spark plug cap). This was obviosly letting spark leak to the block. I did try my coilpack on another bike and it worked but i suppose this was just bad luck and due to the irratic nature of the problem. my mistake was i should have tried working parts on my bike rather then my parts on other bikes or both rather. Anyway the quick fix wich is working for now is epoxy resin coated on the coilpack and i will order the new coilpack soon. Thanks everyone for your input and i hope this helps someone else to Braaaaap on ..!

  • RMK800

Posted March 17, 2014 - 05:40 AM




Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.