Jump to content

  • Follow us:

  • Facebook
  • YouTube
  • Twitter
  • Google+
  • RSS Feed




Related Reviews

Honda NC700X DCT ABS 2012


No reviews available
Be the first to review this

Victory Hammer 8-Ball 2013


No reviews available
Be the first to review this

Kawasaki ZX1000 Ninja ZX-10R 2013


No reviews available
Be the first to review this

Honda GL1800HPNM Gold Wing Audio/Comfort/Navi/XM/ABS 2012


No reviews available
Be the first to review this

Kawasaki ZX1000 Ninja 1000 ABS 2014


Last review by cowpie
* * * * *


Related Garage

Yamaha XJ550 Maxim 1982.jpg

Yamaha XJ550 Maxim (1982)


Owner: cappy1983
Added on Yesterday, 07:52 PM


Photo
- - - - -

Harley 883 sportster 2005 issue with carb


  • Please sign in to reply

2 replies to this topic
  • rodgini

    TT Gold Member

1,387 posts
Location: Virginia

Posted 02 October 2013 - 07:34 PM


Well my wife's co worker brought his 2005 Harley 883 over the house tonight. I'm a dirt guy but offered to take a look at it. It had a slight hesitation off idle which I'm sure could have been cured with the air screw. Well the bike sat for a long time so we figured we'd clean the carb as well. So we pull it off and cleaned the jets. I didn't pull the needle or slide out but i just pulled the bowl, cleaned the pilot jet and main out. Put the thing back together and it won't run worth a crap now? It runs pig rich and loads up and cuts out under load. It puts out puffs of black smoke under load as well. It will start and idle ok and even rev up ok stationary.....but once under load it cuts and won't run. So now I feel like an idiot as I have to give dude a ride home and his bike is in my garage. I pulled the carb back off to double check it was put together properly......everything looked fine. Any thoughts? The bike is in great shape with 7000 miles.

  • HodaddyB

    TT Bronze Member

408 posts
Location: California

Posted 17 December 2013 - 03:29 PM


If you still have the problem (I realize this post has been sitting here awhile), the easiest thing to look at would be the enrichener. That is to say, ensure it is not partially engaged. Presuming that everything is reassembled properly inside the float bowl, the enrichener being off-seat would certainly cause this sort of problem.

 

Hope it's that simple.



  • pellet

    TT Newbie

21 posts
Location: Indiana

Posted 16 April 2014 - 08:12 AM


Check slide diaphram if its a CV carb.







Related Content

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.