Anyone have a petcock problem with Clarke tank?

7 replies to this topic
  • MotoGreg

Posted December 12, 2003 - 09:52 PM


I had a Clarke 3.3 gallon YZF tank on my bike for a while, the one that a lot of people here use on their WR's with the YZF style seat. I sold it to a guy (thanks to TT) yesterday and when he put it on his bike today he said there is a gas leak around the petcock. He took it back off and flipped the o-ring over and it still leaked, but not as bad. I never had any problem when the tank was on my bike. His bike is an '02 yzf426 so it seems odd that the 0-ring seal would be bad already, but I guess it is possible. Has anyone else had a problem with that?

  • tp3dxf

Posted December 12, 2003 - 10:08 PM


I have the Clarke tank on my WR426. Today while working on my bike I happened to notice that the gasket was all cracked. It's not leaking but I should probably replace it soon. I put the tank on about a year ago.

  • Moto-Mike

Posted December 13, 2003 - 07:08 AM


I had the same problem when I bought a used IMS tank. After several failed attempts to stop the leak I called IMS. They sent me, free of charge a thick gasket to go between the petcock and the tank. Problem solved. Kudos to IMS. Even if they charged a little it would have been well worth it. :)

  • RCannon

Posted December 13, 2003 - 11:42 AM


I had the problem on an IMS tank. I ended up fixing it by using some silicon lube/ sealer (quite thick) on the o ring. With the stock factory gasket, the surface has to be perfect!

I used a knife sharpening stone to make the area smooth first.

Overall, the IMS tank sucks.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Ridin'_MD

Posted December 13, 2003 - 01:29 PM


I had the same problem with my NEW tamk from clarke....I actually removed the gasket and put the petcock directly on the plastic..NO LEAK!!!
Works great for me and I cant see what the drawbacks would be. Have him try that.
I have changed tanks many times always using the gasket for stock and no gasket with the Clarke.

Good luck, Bud :)

  • Pazzo_P

Posted December 13, 2003 - 02:19 PM


I had the same problem, fixed it using this on the petcock O-ring ”Permatex Form-a-gasket 2B”. It's Gas/Kerosene specific. Get it at any Auto parts store. Over 14 X/C races and no leakage. :)

  • dirtbikindad426

Posted December 13, 2003 - 04:10 PM


I went and got a new petcock gasket and put it on works like a charm. Thanks guys.

  • PowerFiend

Posted December 18, 2003 - 07:54 AM


Just put an IMS tank on my 02 WRF and had to replace the stock petcock o-ring style gasket due to leakage. It was already hardening.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.