Blowing headlight after Tusk install


3 replies to this topic
  • ZZ4Blazer

Posted May 09, 2013 - 09:23 AM

#1

Blown 2 headlight bulbs here in a week.

Tusk doesnt really change the wiring for the headlight if your not familiar. It simply takes factory power wire from the headlight, into their switch, then back to the headlight.

I used their brake/tail/plate mount. Thats connected to the battery via their harness.

Stock tail light was unplugged and unused. Since thats led as well, I cant imagine that the stock tail light was drawing enough power to keep the headlight in check. And that tusk never bothered mentioning it in the instructions or that anyone else had run across that problem.

Or am I wrong, and I should connect the factory hot for the stock tail light, to the new tail light?

As soon as the bike got any kinda off idle rpms, the headlight blew. High beam blew asap as I turned it on too. Bikes new to me, so first bulb I figured was just old.

I know when I was installing the kit, the high and low both worked for a bit at idle when I was testing all the wiring. Ive put 3 hours of trail riding on, I probably never noticed that the headlight wasnt on since it was all mid afternoon bight sun riding.

I havent checked the voltage at the headlight yet, Im gonna do it as soon as I get home from work. Didnt have any more time last night to mess with it.

Id assume any more than like 14v, the regulators at fault?

Im supposed to leave tmrw evening for a week of riding and fishing, I need to get this fixed asap.

  • ZZ4Blazer

Posted May 09, 2013 - 12:41 PM

#2

So I guess with the choke on and high idle, 30 is a bit too high?? Idling at 1800, its still pushing 18-19.

Plugged the factory rear light back in, made no difference in readings either. So Id assume atleast that parts not an issue

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • SurfaceToAir

Posted May 09, 2013 - 08:23 PM

#3

what year / model is your bike? ( nevermind- I see its an 08 now..)

< sorry- big edits to this post after re-reading yours.. >

I am wiring my bike up now and bypassed the stock light wire all together and ran it off the power from my harness which is powered off the battery ( via a relay ), through the switch, which sounds a little different than you. My low and high beam are both powered from my switch.

Are you running the low beam off the stock wire, and high through a second / parallel circuit through your switch? If so, I wonder if running the bright and low beam together would cause this?

More than 14 volts does seem high. Not sure why the lights would get that current

cheers-
Dustin

Edited by SurfaceToAir, May 09, 2013 - 08:28 PM.


  • ZZ4Blazer

Posted May 10, 2013 - 01:31 AM

#4

The stock headlight, at the white weatherpack connection, has the power and ground going in. And power for the high, power for the low, and ground going out on the other side of the connector connecting to the headlight bulb itself.

Theres only one power wire going in, since only the low beam is wired up. Theres a rubber insert in the empty space where the hot wire for the high beam would go.

I took the green hot wire coming off the harness, and unpinned it from the white connector. I connected that to the new high/low switch from tusk. That now gets switched to high or low(one or other). Those 2 switched hot wires coming from the switch, those get attached to the low beam/ high beam wires on the headlight bulb socket. Those 2 high/low wires were unpinned from the factory connector as well.

None of the factory wiring was cut or really changed for the matter. I more or less just added a switch before the power gets to the headlight socket.

Like I said, high idle with the choke on, around 3k rpms I think, I was seeing close to 30 VAC. That should be less than half that. Now I gotta try and track down a rectifier/regulator assembly today.None of the 20 dealers within and hour or so said they stock them. One of the parts guys said he might be able to pull one off a bike they have in the showroom for me. But that's over an hour away and Im not off till 4 tonight. I was supposed to be on the road by 4:30 this afternoon so I could fish by dark.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.