2012 WR450 Hard Starting sometimes?

6 replies to this topic
  • T_Olie

Posted April 22, 2013 - 07:41 PM


Hey all,

I have a 2012 WR450 with comp ECU, GYTR slip, Throttle screw replaced. and on the basic GYTR tune with the GYTR tuner for the slip on pipe.
I am currently having issues with starting sometimes. It starts fine cold when the cold temp button is pulled but when its warm i notice that I have to barely turn the throttle to make it start. Its like it needs a tad bit of fuel to start it. Not a huge concern. Just looks bad when all the KTM riders are horse laughing me. Until they see me blow by ah ha.

Any Help would be awesome.

Also have IMS black fuel tank. Had more starting issues since the upgrades. But i only had it stock for one day.


  • tomerb

Posted April 22, 2013 - 09:09 PM


Yes you will need to barely turn the throttle to make it start when its warmed up. Mine would start first push of the button if you crack the throttle before hitting the start button. They don't need more fuel it needs more air to start when hot.

Edited by tomerb, April 22, 2013 - 09:11 PM.

  • miweber929

Posted April 23, 2013 - 04:25 AM


Do some searching as this is probably the #1 '12 WR question on here.

It'll get better with time and the upgraded ECU with a good map helps as well. Some people had luck with their dealer making changes that the "special dealer" tuner can do as well.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • cwallershasta

Posted April 23, 2013 - 05:36 AM


Tons of info on here, but the throttle is the hot start, I crack mine about an 1/8 and hit the button once, release it and hit the button again and it usauly works fine.

  • GP1K

Posted April 23, 2013 - 07:10 AM


Join the club. Mine starts find cold, but can be a bear when hot. I had my dealer use the 'special dealer' tuner and it still does it. :(

  • xXNewfie709Xx

Posted May 04, 2013 - 03:38 PM


My bike is the exact same setup as yours man and I have the same issues. Its so bad sometimes that I'll kill the battery trying to use the electric start and Ill have to bump start it. Even kicking it over wont work sometimes.

  • 080

Posted May 05, 2013 - 01:38 PM


What different elevations are you guys riding in? I haven't had any issue's with mine yet ( only 2 rides) stock, uncorked, hot or cold. I'm kinda curious, I'm in low desert approx. 1500ft.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.