Really cool crack in the 'ol pistony


4 replies to this topic
  • jroon

Posted March 31, 2013 - 04:14 PM

#1

Howdy folks! I am not so much looking for advice as I am for precedent. I pieced together yet another 426(2000). Now, I took the lazy way out, I did a rod kit, and did a pretty thorough inspection of everything else, but used the old piston. After a season of beating its brains in at the ice races, it lost power at the last race and I shut her down. The post mortem showed a crack right across the center of the piston, right through! I can't believe I didn't wreck anything else. So, my question is, does this strike you as normal for a high hour piston that has been thrashed up near the rev limiter? Has anyone seen a piston crack like this? Our ice tracks are 4rth and 5th gear pinned at times, so the poor thing was pretty stressed with my chunky butt on it.

Thanks for any info you may offer.

Attached Thumbnails

  • smallSt. Andrews-20130331-00946.jpg

Edited by jroon, March 31, 2013 - 04:21 PM.


  • Peterrides

Posted March 31, 2013 - 04:38 PM

#2

Wow.. Good thing you shut her down.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • SWIGIN

Posted April 05, 2013 - 01:25 PM

#3

My buddy's and I all have YZ powered custom quads and the one guy had this happen 2 times. The first was a Wiseco piston that came in the motor he got so it had unknown hours. The second time was a year or so later and it was an Arias piston.

We have no idea how this happened but it seems to be from piston flex. It just so happens that we all rebuilt our motors at the same time when he found the second cracked piston and we are all running JE pistons now.... we will see how they do.

Edited by SWIGIN, April 05, 2013 - 01:27 PM.


  • zeuszuki

Posted April 05, 2013 - 06:37 PM

#4

It is consistent with the gudgeon pin holes, a highly stressed area thermally and mechanically so with enough prolonged stress you have observed one of many potential failure scenarios. Impressive :-)

  • jroon

Posted April 15, 2013 - 02:31 PM

#5

Thanks for the input fellows, sorry for the late reply, I don't seem to be getting email notifications when I get a reply. I will have to look into that.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.