Need your help, hopefully fast


19 replies to this topic
  • Jtt_R

Posted February 07, 2013 - 06:22 PM

#1

Gentlemen,

I need your help and hope fully you guys can get it to me fast(supposed to ride this weekend and next). I am having some issues from idle to 1/4. Bike is an 07 yz450. I had a bad stator so i replaced it and now the bike stumbles from idle to 1/4. After that it runs like a top. I'm running a 45 pilot with the fuel screw 1 3/4 out. I've messed with my idle speed a bit but I think it's where is should be. I don't have a wireless tach to confirm that though. I have turned the fuel screw in and out in 1/4 increments and it doesn't help. I also disconnected the TPS which seemed to help a little but I'm not one for quick fixes and would like to figure out what is going on WITH the TPS connected. Any ideas. I already ran a search and from what I read there is nothing I haven't tried or looked into.

Thanks

Pic for clicks!335763_3669542621143_742312639_o.jpg

Edited by Jtt_R, February 07, 2013 - 06:26 PM.


  • marv02

Posted February 07, 2013 - 06:33 PM

#2

Clean out the pilot jet with compressed air.

  • Jtt_R

Posted February 07, 2013 - 06:36 PM

#3

Done..one of the first things I did

  • marv02

Posted February 07, 2013 - 06:49 PM

#4

Do you have a hot start on you'r carb see if sticking open I had this problem before.

  • Jtt_R

Posted February 07, 2013 - 07:02 PM

#5

I will double check it tomorrow. it's a little late here to be running the bike. I will let you know what I find out. In the mean time any other suggestions?

  • marv02

Posted February 07, 2013 - 07:08 PM

#6

Did you have the Slide out I know my 2005 carb you can install the front side plate up side down take a look at that.

Did you change the needle postion I know the needle from 1/4 to 3/4 throttle but you never know.

Will the bike idle have you reoiled the air filter.

  • Jtt_R

Posted February 07, 2013 - 07:21 PM

#7

I did not have the carb apart so the slide isn't the issue. The bike idles fine except I don't know if the idle rpm ids where it should be. And the needle is in the stock position.

Also it has a brand new filter that is oiled lightly

  • squirrel 830

Posted February 08, 2013 - 05:36 AM

#8

I just had the same problem, plus the bike would bog after every jump landing. The one way check valve in the gas cap wasn't functioning correct so the tank was pressurizing. Probably worth checking since you would just run it for a minute and screw the cap off and see if the tank is building pressure. I put a new cap on a cured it. Good luck.

  • marv02

Posted February 08, 2013 - 05:56 AM

#9

I would pull the pilot jet back out hold it up to a light source and see if there's light coming though it and clean it out again was the bowl of the carb when you took if off last time have junk in it or old gas.

  • Jtt_R

Posted February 08, 2013 - 06:00 AM

#10

I'll double check the pilot after work today. I may try a bigger one too. I've done some deeper digging and reading and it seems a lean condition can bbw the problem. I had the bowl drain off yesterday and the fuel was clean. And it was fresh gas or in the tank.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • marv02

Posted February 08, 2013 - 06:16 AM

#11

Un less you done some motor mods or things like that and the motor ran good before what ever pilot jet ([color=#B22222]Or any of the Jetting[/color]) you had in it before should be the same.

I just put a big bore kit in my bike I been playing with the jettting because of the motor mods I had to go to 2 sizes bigger Pilot drop the Needle 2 slots and go to a larger main jet.

You said before when you play with the fuel screw it didn't change any thing thats why I think it your pilot jet if it runs when the fuel screw is all the way in the bike should want to quit running as you screw it out it should start cleaning the idel up if it dont do nothing most likely you need to go to the next higher pilot. (If you turn the Fuel screw more than 3 turns out from full seat it to lean go the next bigger pilot jet).

If the idel starts to clean up get it to the highest idel then a 1/4 more turn out.

If you turn the screw in and it has no effect the idel It it could be to rich then you go smaller pilot or if it boggs chugs before it rev's out cleanly.

Edited by marv02, February 08, 2013 - 06:29 AM.


  • stroker101

Posted February 08, 2013 - 06:22 AM

#12

if the stator was the only thing replaced, why look at the carburator??? you had mentioned dissconnecing the TPS helped smooth out the roughness. perhaps the stator is not "clocked" "positioned" correctly ??? and the TPS is not calibrated with the misalignment???

Edited by stroker101, February 08, 2013 - 06:27 AM.


  • marv02

Posted February 08, 2013 - 06:31 AM

#13

if the stator was the only thing replaced, why look at the carburator??? you had mentioned dissconnecing the TPS helped smooth out the roughness. perhaps the stator is not "clocked" "positioned" correctly ??? and the TPS is not calibrated with the misalignment???


On my 2000 426 the stator only go's in one way I dont know about his bike but you have a good point about the stator clocking Kudo's on that point.

Edited by marv02, February 08, 2013 - 06:31 AM.


  • stroker101

Posted February 08, 2013 - 06:36 AM

#14

i'm not a mechanical or technical GURO (LOL) by any means,...but something to look at again.
i hope you find the problem

  • zachrips49

Posted February 08, 2013 - 06:41 AM

#15

Run a 48 pilot instead of the 45. I had the same problem on my 06'

  • Jtt_R

Posted February 08, 2013 - 07:01 AM

#16

Un less you done some motor mods or things like that and the motor ran good before what ever pilot jet ([color=#B22222]Or any of the Jetting[/color]) you had in it before should be the same.

I just put a big bore kit in my bike I been playing with the jettting because of the motor mods I had to go to 2 sizes bigger Pilot drop the Needle 2 slots and go to a larger main jet.

You said before when you play with the fuel screw it didn't change any thing thats why I think it your pilot jet if it runs when the fuel screw is all the way in the bike should want to quit running as you screw it out it should start cleaning the idel up if it dont do nothing most likely you need to go to the next higher pilot. (If you turn the Fuel screw more than 3 turns out from full seat it to lean go the next bigger pilot jet).

If the idel starts to clean up get it to the highest idel then a 1/4 more turn out.

If you turn the screw in and it has no effect the idel It it could be to rich then you go smaller pilot or if it boggs chugs before it rev's out cleanly.


It did die when turned in, I meant the minor adjustments didn't change until it was to the obvious to rich/lean.

Run a 48 pilot instead of the 45. I had the same problem on my 06'


I have a couple different sizes I'll bee trying out today.

  • grayracer513

Posted February 08, 2013 - 07:45 AM

#17

If the bike sat for a time, you may have a varnish deposit in the pilot that you won't be able to clear with air or sprays:

http://www.thumperta...726#post8021726

Also check float level, air leaks, etc. Check the accelerator pump timing and squirt duration per the manual.

A clean #45 should be right most of the time.

Idle speed is not too critical. Basically, set it to as slow as the bike will idle stably and not stall more than usual.

  • Jtt_R

Posted February 08, 2013 - 02:11 PM

#18

Ok, the bike now has a brand new 48 pilot with fuel screw 2 turns out. That is where it is least noticeable. I've tried with the tps connected and disconnected and no change. It's definitely not a valve the bike starts with one kick.

  • Jtt_R

Posted February 08, 2013 - 02:13 PM

#19

It feels like a clutch slipping then grabbing then slipping and grabbing.

  • grayracer513

Posted February 09, 2013 - 06:14 PM

#20

Does this happen only under a load?

With less load it doesn't, but any more than a certain amount it does?

Only in one gear?





Related Content

Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
Forums
Photo

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F


Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.