Headlight keeps popping.


10 replies to this topic
  • wayne10810

Posted February 04, 2013 - 08:27 PM

#1

My 2009 WR450 keeps popping the headlight, I changed the Regulator/rectifier (which is usually what causes this to happen), but the problem is still there. It blows after a minute or so of riding.

Any advice on this please (planning a long trip soon and a headlight would be handy!)


Thanks

  • miweber929

Posted February 04, 2013 - 09:57 PM

#2

Get a multimeter and follow the directions in the manual for checking things. You buy a brand new RR or was it used? What other mods are done to the bike? Electrical wise to stray with.



  • wayne10810

Posted February 04, 2013 - 10:13 PM

#3

It was a used RR, is there any way of testing them? my previous 2006 WR also needed a new one.

Mods on the bike are an indicator set (of which they don't flash, they stay shining when u flick the switch left or right - need to fix that too! - bought the bike with the mod).

that's all. battling to find a good bike electrician, so kinda stuck!

  • Do I Care?

Posted February 04, 2013 - 11:13 PM

#4

Sounds to me like there is a power wire grounded somewhere or bad earth.
Check all wires have no cuts in them & are not grounding to the frame or crossing.
Next would be to test the wires going to the headlight to see if there is irregular/fluctuating power as this could have something to do with your ressistor/regulator. All power after the regulator will be a closed circuit ie. 11.8V-12V no higher!
Next thing is to check that you have a good open circuit reading from the magneto/stator coil. This will be higher than 12V & should be over 12V at 20 degrees celcius & can go up as high as 200V when the engine is cranked.
Best bet is the crossed/earthed or bad earth though.

Edited by Barra8, February 04, 2013 - 11:15 PM.


  • wayne10810

Posted February 04, 2013 - 11:18 PM

#5

Sounds to me like there is a power wire grounded somewhere or bad earth.
Check all wires have no cuts in them & are not grounding to the frame or crossing.
Next would be to test the wires going to the headlight to see if there is irregular/fluctuating power as this could have something to do with your ressistor/regulator. All power after the regulator will be a closed circuit ie. 11.8V-12V no higher!
Next thing is to check that you have a good open circuit reading from the magneto/stator coil. This will be higher than 12V & should be over 12V at 20 degrees celcius & can go up as high as 200V when the engine is cranked.
Best bet is the crossed/earthed or bad earth though.

Thanks , very much appreciated. Will let u know the outcome.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Do I Care?

Posted February 04, 2013 - 11:23 PM

#6

No problems :thumbsup: If you have questions i'll be here (bearing in mind i don't own a WR)

  • RickyStator

Posted February 05, 2013 - 09:12 AM

#7

if it is still popping the bulb when you rev it the "new regulator" is most likely bad. it has a good ground as the bulb lights up, if it had a bad ground the bulb would not light.

  • Do I Care?

Posted February 05, 2013 - 07:32 PM

#8

if it is still popping the bulb when you rev it the "new regulator" is most likely bad. it has a good ground as the bulb lights up, if it had a bad ground the bulb would not light.


Yes that is correct but i am not the one looking at the bulb ;) Bad earths blow bulbs too ;)
I'd be looking more along the lines of a crossed wire or eathed headlight power wire as this could be the cause of your rectifier/ressistor blowing up on you.

Edited by Barra8, February 05, 2013 - 07:38 PM.


  • o313

Posted February 07, 2013 - 02:45 PM

#9

Yes that is correct but i am not the one looking at the bulb ;) Bad earths blow bulbs too ;)
I'd be looking more along the lines of a crossed wire or eathed headlight power wire as this could be the cause of your rectifier/ressistor blowing up on you.


I relocated my road controls (street legal 2007 WR450) to the top clamp (HDB) and used a cheap as$ toggle from radio shack for the headlight switch, one night we were getting done with a ride and had to go back out to look for a lost MT Biker. During my search the switch fell apart and shorted out destroying the regulator rectifier in the process! riding at night in the mountains with with my blinkers on was not optimal. The moral of the story is if your RR was "Bad" and you replaced it without fixing the underlying issue then the new RR probably met the same fate.

Look for a wire shorted out or a ground that came loose.

  • Do I Care?

Posted February 07, 2013 - 03:53 PM

#10

Sounds to me like there is a power wire grounded somewhere or bad earth.
Check all wires have no cuts in them & are not grounding to the frame or crossing.
Next would be to test the wires going to the headlight to see if there is irregular/fluctuating power as this could have something to do with your ressistor/regulator. All power after the regulator will be a closed circuit ie. 11.8V-12V no higher!
Next thing is to check that you have a good open circuit reading from the magneto/stator coil. This will be higher than 12V & should be over 12V at 20 degrees celcius & can go up as high as 200V when the engine is cranked.
Best bet is the crossed/earthed or bad earth though.

I relocated my road controls (street legal 2007 WR450) to the top clamp (HDB) and used a cheap as$ toggle from radio shack for the headlight switch, one night we were getting done with a ride and had to go back out to look for a lost MT Biker. During my search the switch fell apart and shorted out destroying the regulator rectifier in the process! riding at night in the mountains with with my blinkers on was not optimal. The moral of the story is if your RR was "Bad" and you replaced it without fixing the underlying issue then the new RR probably met the same fate.

Look for a wire shorted out or a ground that came loose.


That is why i wrote this :rolleyes:

Oh & this...

Yes that is correct but i am not the one looking at the bulb ;) Bad earths blow bulbs too ;)
I'd be looking more along the lines of a crossed wire or eathed headlight power wire as this could be the cause of your rectifier/ressistor blowing up on you.


Edited by Barra8, February 07, 2013 - 04:06 PM.


  • wayne10810

Posted July 02, 2013 - 11:19 PM

#11

Sorry for the delayed response, and thanks to all the guys that posted. I did a hunt for earthed wires etc., and eventually bought ANOTHER Regulator/rectifier (a cheaper chinese one, not from Yamaha - incase it wasn't the problem) turned out it WAS the problem! I have ridden for over a month on this one and all seems fine. Bloody hell!




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.