Are they friends?


11 replies to this topic
  • lukey_muffler

Posted January 19, 2013 - 03:34 PM

#1

I have been having some electrical issues with my 99 wr 400. I have access to a wiring harness complete with cdi magneto etc. From a 98 yz 400. I had previously stripped all the lights off the bike for racing, so it might as well be a yz. Just wanted to know, are these two models friends, will this work?

  • Krannie McKranface

Posted January 19, 2013 - 04:22 PM

#2

I have been having some electrical issues with my 99 wr 400. I have access to a wiring harness complete with cdi magneto etc. From a 98 yz 400. I had previously stripped all the lights off the bike for racing, so it might as well be a yz. Just wanted to know, are these two models friends, will this work?


Nope.
No charging, no DC (no rectifier) with the YZ system.

  • lukey_muffler

Posted January 19, 2013 - 04:45 PM

#3

No battery with the 400, I took the rectifier out ages ago when the lights came off.

  • miweber929

Posted January 19, 2013 - 10:15 PM

#4

Nothing to do with a battery, your CDI and other ignition related parts run on DC power on your WR and AC power on the YZ.

They won't play, like Krannie said.

  • Birdy426

Posted January 19, 2013 - 11:38 PM

#5

Not sure about the harness working or not right out of the box...YZs had a pink wire that the WRs didn't have...however, the 98-02 WRs were 100% AC power, and had a regulator, not a regulator/rectifier. You can run a WR magneto on a YZ to give it enough juice to power lights. If you have the CDI box, I would expect that it would be a simple swap out as long as you don't want lights. If you don't have the CDI box and need to run the WR box, keep the gray wire disconnected, and, I think, ground the pink wire...that's what you have to do to run the WR stator on the YZ, so it would make sense to have to do that to run the WR CDI and harness on the WR. Remember, the whole gray wire mod on the WRs was based on the fact that the WR used the YZ CDI, and searched for a ground at the gray wire to decide which map to use...

  • lukey_muffler

Posted January 20, 2013 - 11:36 AM

#6

I'm leaning toward the CDI being the root of my problems, however I figured that If I can pick up the magneto ect. that I could cover all bases and surely it would live again!
So the outcome of all this is that the early wr's run an AC system like the yz's and parts are interchangable, just need some wiring mods done?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Birdy426

Posted January 20, 2013 - 11:55 AM

#7

I'm leaning toward the CDI being the root of my problems, however I figured that If I can pick up the magneto ect. that I could cover all bases and surely it would live again!
So the outcome of all this is that the early wr's run an AC system like the yz's and parts are interchangable, just need some wiring mods done?


That's about right. If you are going to run the WR stator and YZ harness and CDI box, do a search here on "pink wire mod"...if you are going to run the WR stator and WR CDI with YZ harness, download both wiring diagrams and do a "pin to pin" assessment between the two. If you are going to run the YZ stator and CDI with the YZ harness, it's just a bolt-across.

  • miweber929

Posted January 21, 2013 - 03:18 AM

#8

Not sure about the harness working or not right out of the box...YZs had a pink wire that the WRs didn't have...however, the 98-02 WRs were 100% AC power, and had a regulator, not a regulator/rectifier. You can run a WR magneto on a YZ to give it enough juice to power lights. If you have the CDI box, I would expect that it would be a simple swap out as long as you don't want lights. If you don't have the CDI box and need to run the WR box, keep the gray wire disconnected, and, I think, ground the pink wire...that's what you have to do to run the WR stator on the YZ, so it would make sense to have to do that to run the WR CDI and harness on the WR. Remember, the whole gray wire mod on the WRs was based on the fact that the WR used the YZ CDI, and searched for a ground at the gray wire to decide which map to use...


Learn something new everyday. Looked it up a while ago for something else and swear the WR was a DC system and regulated/rectified. Good info to know.

  • Birdy426

Posted January 21, 2013 - 06:40 AM

#9

Learn something new everyday. Looked it up a while ago for something else and swear the WR was a DC system and regulated/rectified. Good info to know.

Beginning in 03 with the electric start, WRs have both an AC component (for ignition) and DC component for the starter and battery. I'm honestly not sure if the lights are powered by AC or DC on the 03 and up WRs...

  • miweber929

Posted January 21, 2013 - 07:08 AM

#10

Beginning in 03 with the electric start, WRs have both an AC component (for ignition) and DC component for the starter and battery. I'm honestly not sure if the lights are powered by AC or DC on the 03 and up WRs...

AC for the lights on the electric start models, but I meant to specify I looked at the electrical system of a an "older" WR, a 426 because I was going to buy one originally before I found my 04 and wanted to know what the electrical system would be to dual sport it.

Edited by miweber929, January 21, 2013 - 07:08 AM.


  • lukey_muffler

Posted March 05, 2013 - 11:25 PM

#11

It lives! No conversion needed cause I dont have lights on it. Very happy!!

  • Do I Care?

Posted March 09, 2013 - 11:41 AM

#12

Okay,first of all
AC current is alternating current
DC is direct current
A DC light bulb will NOT run on AC current.

I thought I would clear up some confusion. When an AC magneto is fitted,it's job is to generate power to charge the battery. AC current CANNOT touch DC current or it will ''fry'' whatever it touches. Given that,it has to go through the rectifier/resister which it then becomes a DC current so it can charge the battery. It then runs into the main switch,then CDI & comes out to run the ignition coil, lights etc. The charging circuit on most bikes run into this also so some of the power is generated by the AC magneto.


On the other hand,the pick-up is what generates the AC power (which is only a small 3-4 Amp pulse) that runs to the coil. It's job is to come out,from the pick-up at the right moment (which it does by sensing where TDC is by magnets) then gets grounded, goes to the Cdi,then runs to the coil,then through the neutral switch,clutch switch,start switch and back to the AC side of the starter relay. It also has a diode which would take me too long too describe what it does,but is part of the trigger mechanism (pulse) that goes to the CDI to tell it when to fire the ignition coil,but you should get the point by now.

Edited by Barra8, March 14, 2013 - 06:23 AM.





 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.