clutch cable?


1 reply to this topic
  • Jtt_R

Posted January 19, 2013 - 11:58 AM

#1

So I started my bike up and put it in gear on the stand and the tire start to turn more then it should. I tried adjusting the cable but nothing helped the tire is spinning just as much with the clutch engaged as it does when its disengaged. I'm leaning towards the cable being stretched and needing replacement. Any other ideas? Thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • etuke

Posted January 19, 2013 - 01:31 PM

#2

on the stand isn't a good indication,try it on the ground and let out the clutch until you get drag.Leave a lil bit of slack in the cable when adjusted just to make sure the clutch is fully engaged.Its normal for the tire to spin on the stand even in neutral as there is allways some drag on gears and such transmitted through the spinning shafts and oil between gears.With all that said its possible you have a bad clutch,like warped plates causing it not to fully disengage with the clutch pulled in.

Edited by etuke, January 19, 2013 - 01:33 PM.






Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.